1085 Perfect Sequence (25分)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

坑点 :请使用long long 代替 int,最后一个节点会超范围

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int main(){
    
    long long int n, p;
    cin >> n >> p;
    vector<long long int> vec(n);
    for(long long int i = 0; i < n; i++){

        scanf("%lld", &vec[i]);
    }
    sort(vec.begin(), vec.end());

    long long int cnt = 0;
    long long int max_index = 0;
    for(long long int i = 0; i < n; i++){

        while (vec[max_index] <= vec[i] * p && max_index < n)
        {
            max_index++;
               
        }
        cnt = max(cnt, max_index - i);
        if(max_index >= n){
            cout << cnt << endl;
            return 0;
        } 


    }


    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值