目录
题目描述:
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3303 Accepted Submission(s): 2202
Problem Description
RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:
> choose two large prime integer p, q
> calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
> choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
> calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key
You can encrypt data with this method :
C = E(m) = me mod n
When you want to decrypt data, use this method :
M = D(c) = cd mod n
Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.
Now given p, q, e and some cryptograph, your task is to "translate" the cryptograph into plain text.
Input
Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks.
Output
For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.
Sample Input
101 103 7 11 7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239
Sample Output
I-LOVE-ACM.
Author
JGShining(极光炫影)
Source
Recommend
Eddy
题意:
给定l个加密字母的ASCII值,通过题目中给出的操作让我们求出明文。
题解:
按照逆顺序进行分析,给定一串密文的ASCII值,我们要求明文,那么我们就用把这一串数字带入到M = D(c) = c d mod n 中,其中c是我们输入的数字,而在这里d和n是未知的,那么我们就分别求d和n。
1:求d:
根据题意: d × e mod F(n) = 1 mod F(n) ,问题就分解为在一个式子里面求未知数,因为F(n)=(p - 1) × (q - 1) ,所以我们只需求e就行了。
根据上图,我们要求d的话,就要求e,由于分式取余要用到逆元,所以我们的问题就分解成求逆元。
choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
虽然e和F(n)的最大公因数为1,但是不一定满足互素,所以不能用欧拉定理来求逆元。
2:求n:
根据题意,n=p*q;
代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<map>
typedef long long ll;
using namespace std;
ll p,q,l,n,fn,e,va,x,y;
ll euler(ll a,ll b, ll c)
{
ll ans=1;
while(b)
{
if(b%2==1) ans=ans*a%c;
a=a*a%c;
b>>=1;
}
return ans;
}
void extend_gcd(ll a, ll b, ll &x, ll &y)//ax+by=1返回a,b的gcd
{
ll t;
if(b == 0)
{
x = 1;
y = 0;
return ;
}
extend_gcd(b,a%b,x,y);
t = x;
x = y;
y = t-(a/b)*y;
return ;
}
int main()
{
while(~scanf("%lld%lld%lld%lld",&p,&q,&e,&l))
{
n=p*q;
fn=(p-1)*(q-1);
extend_gcd(e,fn,x,y);
if(x<0)
x+=fn;
while(l--)
{
scanf("%I64d",&va);
printf("%c",euler(va,x,n));
}
printf("\n");
}
return 0;
}