nyoj 353 3Ddungeon 搜索

题目描述

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

输入

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

输出

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

样例输入

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

样例输出

Escaped in 11 minute(s).

Trapped!

题意:一个简单的搜索题,是一个三维模型,让求从'S'走到'E'的最小时间,'.'可以走,'#'不可以走 思路:其实和二维唯一的不同就在于定义的几个方向,然后用广搜就解决了,但却因为写错了一个字母导致程序直接崩溃,一直找错了找了半天

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int n,m,s;
int v[100][100][100];
char a[100][100][100];
int a1,a2,b1,b2,c1,c2;
int flag;
int t[6][3]={{1,0,0},{-1,0,0},{0,0,1},{0,0,-1},{0,1,0},{0,-1,0}};
struct p
{
    int x,y,z,step;
};
void bfs()
{
   p now,tmp;
   queue<p>Q;
   now.x=a1;
   now.y=b1;
   now.z=c1;
   now.step=0;
   v[a1][b1][c1]=1;
   Q.push(now);
   while(!Q.empty())
   {
       now=Q.front();
       Q.pop();
       if(now.x==a2&&now.y==b2&&now.z==c2)
       {
           printf("Escaped in %d minute(s).\n",now.step);
           flag=1;
           return;
       }
       for(int i=0;i<6;i++)
       {
           int tx=now.x+t[i][0];
           int ty=now.y+t[i][1];
           int tz=now.z+t[i][2];
           if(tx>=0&&tx<n&&ty>=0&&ty<m&&tz>=0&&tz<s&&a[tx][ty][tz]!='#'&&v[tx][ty][tz]==0)
           {
               tmp.x=tx;
               tmp.y=ty;
               tmp.z=tz;
               tmp.step=now.step+1;
               v[tx][ty][tz]=1;
               Q.push(tmp);
           }
       }

   }
   return ;
}
int main()
{
    while(~scanf("%d%d%d",&n,&m,&s))
    {
        memset(v,0,sizeof(v));
        if(n==0&&m==0&&s==0)
            break;
        flag=0;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                scanf("%s",a[i][j]);
                for(int k=0; k<s; k++)
                {
                    if(a[i][j][k]=='S')
                    {
                        a1=i;
                        b1=j;
                        c1=k;
                    }
                    if(a[i][j][k]=='E')
                    {
                        a2=i;
                        b2=j;
                        c2=k;
                    }
                }
            }
        }
        bfs();
        if(flag==0)
            printf("Trapped!\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值