NYOJ-353

22 篇文章 0 订阅
3D dungeon
时间限制:1000 ms  |  内存限制:65535 KB
难度:2
描述
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 


Is an escape possible? If yes, how long will it take? 
输入
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
输出
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!
样例输入
3 4 5
S....
.###.
.##..
###.#


#####
#####
##.##
##...


#####
#####
#.###
####E


1 3 3
S##
#E#
###


0 0 0
样例输出
Escaped in 11 minute(s).

Trapped!

解题思路:bfs 搜索

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
	int x,y,z,t;
	friend bool operator<(node a,node b)
	{
		return a.t>b.t;
	} 
};
int L,R,C,sx,sy,sz,vis[35][35][35];
char maze[35][35][35];
int dx[6]={1,0,0,-1,0,0};
int dy[6]={0,1,-1,0,0,0};
int dz[6]={0,0,0,0,-1,1};
int bfs() 
{
	int i;
	memset(vis,0,sizeof(vis));
	priority_queue<node>q;
	node s,p;
	p.x=sx;p.y=sy;p.y=sy;p.z=sz;
	p.t=0;
	vis[sx][sy][sz]=1; 
	q.push(p);
	while(!q.empty())
	{
		p=q.top();
		q.pop();
		if(maze[p.x][p.y][p.z]=='E')  //走到终点,返回所用时间. 
		{
			return p.t;
		}
		for(i=0;i<6;i++)             //上下左右前后六个方向扩展. 
		{
			s.x=p.x+dx[i];
			s.y=p.y+dy[i];
			s.z=p.z+dz[i];
			if(s.x<0||s.x>=L)  continue;     //判断是否越界 
			if(s.y<0||s.y>=R)  continue;
			if(s.z<0||s.z>=C)  continue;
			if(!vis[s.x][s.y][s.z]&&maze[s.x][s.y][s.z]!='#')   //该位置未走过且不是石头.则走到该位置 
			{
				vis[s.x][s.y][s.z]=1; 
				s.t=p.t+1;
				q.push(s);
			}
		}
	}
	return -1;
}
int main()
{
	int i,j,k,flag;
	while(scanf("%d%d%d",&L,&R,&C)&&(L|R|C)) 
	{
		flag=0;
		memset(maze,0,sizeof(maze));
	    getchar(); 
		for(i=0;i<L;i++)
		{
			for(j=0;j<R;j++)
			{
				scanf("%s",&maze[i][j]); 
			    for(k=0;k<C;k++)
				{
					
					if(maze[i][j][k]=='S')
					{
						sx=i;sy=j;sz=k;
					} 
				}
				getchar(); 
			}
			getchar(); 
		}
		int t=bfs();
		if(t!=-1) 
		 printf("Escaped in %d minute(s).\n",t);
		else 
		 printf("Trapped!\n"); 
	}
	return 0;
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值