poj 3259 Wormholes 最短路

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2..  M+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2..  MW+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1..  F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.


题意:农场上有n块地,m条路径,从a到b花费时间为c, 路径是双向的,有s个虫洞,从a到b使时间倒退c,虫洞是单向的,虫洞的权值为负数,农夫希望从某地出发时间早于回到某地的时间,只需要判断是否存在负环,有负环说明所用总时间为负

Bellman—Ford

#include<stdio.h>
#include<algorithm>
#include<string.h>
#define INF 0x3f3f3f3f
using namespace std;
struct p
{
    int u;
    int v;
    int w;
} e[5500];
int main()
{
    int dis[550],n,m,s,x,y,z;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int sum=1;
        memset(dis,0,sizeof(dis));
        scanf("%d%d%d",&n,&m,&s);
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            e[sum].u=x;
            e[sum].v=y;
            e[sum++].w=z;
            e[sum].u=y;
            e[sum].v=x;
            e[sum++].w=z;
        }
        for(int i=0; i<s; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            e[sum].u=x;
            e[sum].v=y;
            e[sum++].w=-z;
        }
        for(int i=1; i<=n; i++)
            dis[i]=INF;
        dis[1]=0;
        for(int k=1; k<=n-1; k++)
        {
            int cnt=0; //标记在本轮松弛中dis是否会更新
            for(int i=1; i<sum; i++)
            {
                if(dis[e[i].v]>dis[e[i].u]+e[i].w)
                {
                    dis[e[i].v]=dis[e[i].u]+e[i].w;
                    cnt=1;
                }
            }
            if(cnt==0)//dis没有更新,提前退出循环
                break;
        }
        int flag=0;
        for(int i=1; i<sum; i++) //进行n-1次松弛后,仍然可以继续松弛,则存在负权回路
            if(dis[e[i].v]>dis[e[i].u]+e[i].w)
            {
                flag=1;
                break;
            }
        if(flag==1)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
Spfa
#include<stdio.h>
#include<algorithm>
#include<queue>
#include<string.h>
#define INF 0x3f3f3f3f
using namespace std;
int dis[510],vis[510],c[510],next1[5500],head[5500],n;
struct p
{
    int u;
    int v;
    int w;
} e[5500];
int spfa_bfs()
{
    queue<int>Q;
    Q.push(1);
    vis[1]=c[1]=1; //c数组统计次数
    while(!Q.empty())
    {
        int k=Q.front();
        Q.pop();
        vis[k]=0;

        for(int i=head[k]; i!=-1; i=next1[i])
        {
            if(dis[e[i].v]>dis[e[i].u]+e[i].w)
            {
                dis[e[i].v]=dis[e[i].u]+e[i].w;
                if(vis[e[i].v]==0)
                {
                    vis[e[i].v]=1;
                    Q.push(e[i].v);
                    c[e[i].v]++;
                    if(c[e[i].v]>n) //入队次数超过顶点数,则有负环
                        return 0;
                }
            }
        }
    }
    return 1;
}
int main()
{
    int m,s,T;
    int x,y,z;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&s);
        for(int i=1; i<=n; i++)
        {
            dis[i]=INF;
            vis[i]=c[i]=0;
        }
        memset(head,-1,sizeof(head));
        dis[1]=0;
        int sum=1;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            e[sum].u=x;
            e[sum].v=y;
            e[sum].w=z;
            next1[sum]=head[e[sum].u]; //构建邻接表
            head[e[sum].u]=sum++;
            swap(x,y);
            e[sum].u=x;
            e[sum].v=y;
            e[sum].w=z;
            next1[sum]=head[e[sum].u];
            head[e[sum].u]=sum++;
        }
        for(int i=0; i<s; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            e[sum].u=x;
            e[sum].v=y;
            e[sum].w=-z;  //虫洞使时间倒退,所以为负值
            next1[sum]=head[e[sum].u];
            head[e[sum].u]=sum++;
        }
        if(!spfa_bfs())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值