2016 Multi-University Training Contest 3 1002 Permutation Bo

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5753

题目:

Problem Description
There are two sequences h1hn and c1cn . h1hn is a permutation of 1n . particularly, h0=hn+1=0 .

We define the expression [condition] is 1 when condition is True,is 0 when condition is False.

Define the function f(h)=ni=1ci[hi>hi1  and  hi>hi+1]

Bo have gotten the value of c1cn , and he wants to know the expected value of f(h) .
 

Input
This problem has multi test cases(no more than 12 ).

For each test case, the first line contains a non-negative integer n(1n1000) , second line contains n non-negative integer ci(0ci1000) .
 

Output
For each test cases print a decimal - the expectation of f(h) .

If the absolute error between your answer and the standard answer is no more than 104 , your solution will be accepted.
 

Sample Input
  
  
4 3 2 4 5 5 3 5 99 32 12
 

Sample Output
  
  
6.000000 52.833333

对于i =1和 i = n,比相邻数大的概率为1/2,而对于中间的数,比相邻数大的概率为1/3。(可以考虑三个数,每个数为最大数的概率为1/3)

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

double a[11000];

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)   scanf("%lf",&a[i]);
        double ans=0;
        ans+=(a[1]+a[n])/2;
        for(int i=2;i<n;i++)
            ans+=a[i]/3;
        printf("%.6f\n",ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值