【多校训练】hdu 6043 KazaQ's Socks

Problem Description
KazaQ wears socks everyday.

At the beginning, he has  n  pairs of socks numbered from  1  to  n  in his closets. 

Every morning, he puts on a pair of socks which has the smallest number in the closets. 

Every evening, he puts this pair of socks in the basket. If there are  n1  pairs of socks in the basket now, lazy  KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the  k -th day.
 

Input
The input consists of multiple test cases. (about  2000 )

For each case, there is a line contains two numbers  n,k   (2n109,1k1018) .
 

Output
For each test case, output " Case # x y " in one line (without quotes), where  x  indicates the case number starting from  1  and  y  denotes the answer of corresponding case.
 

Sample Input
  
  
3 7 3 6 4 9
 

Sample Output
  
  
Case #1: 3 Case #2: 1 Case #3: 2
 

题意:

有n双袜子1~n,每天早上选标号最小的一双。晚上发现只剩一双能穿时,就把之前的洗了,明晚就能穿。问第K天穿的是哪一个标号的袜子。

思路:

找规律发现,如果是n双袜子,有1~n-2的时候按顺序穿,只剩一双时奇数轮剩的是n-1,偶数轮剩的是n。

//
//  main.cpp
//  1011
//
//  Created by zc on 2017/7/25.
//  Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cmath>
#define ll long long
using namespace std;

int main(int argc, const char * argv[]) {
    int kase=0;
    ll n,k;
    while(~scanf("%lld%lld",&n,&k))
    {
        ll ans;
        if(k<=n)    ans=k;
        else
        {
            k-=n+1;
            ll t1=k%(n-1);
            ll t2=k/(n-1);
            if(t1<=n-3) ans=t1+1;
            else ans=n-1+(t2&1);
        }
        printf("Case #%d: %lld\n",++kase,ans);
    }
        
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值