【多校训练】hdu 6077 Time To Get Up

Problem Description
Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has  5  alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times.



Your job is to help Little Q read the time shown on his clock.
 

Input
The first line of the input contains an integer  T(1T1440) , denoting the number of test cases.

In each test case, there is an  7×21  ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.
 

Output
For each test case, print a single line containing a string  t  in the format of  HH:MM , where  t(00:00t23:59) , denoting the time shown on the clock.
 

Sample Input
  
  
1 .XX...XX.....XX...XX. X..X....X......X.X..X X..X....X.X....X.X..X ......XX.....XX...XX. X..X.X....X....X.X..X X..X.X.........X.X..X .XX...XX.....XX...XX.
 

Sample Output
  
  
02:38


题意:

给出时间的图像,打印时间

思路:

模拟,判断特征

//
//  main.cpp
//  1011
//
//  Created by zc on 2017/8/3.
//  Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
char s[110][110];
int d[10];

int cal(int l)
{
    memset(d,0,sizeof(d));
    if(s[0][l+1]=='X')   d[1]=1;
    if(s[1][l]=='X')    d[2]=1;
    if(s[1][l+3]=='X')  d[3]=1;
    if(s[3][l+1]=='X')  d[4]=1;
    if(s[4][l]=='X')    d[5]=1;
    if(s[4][l+3]=='X')   d[6]=1;
    if(s[6][l+1]=='X')  d[7]=1;
    int sum=0;
    for(int i=1;i<8;i++)    sum+=d[i];
    if(sum==2)  return 1;
    if(sum==3)  return 7;
    if(sum==4)  return 4;
    if(sum==5)
    {
        if(!d[2]&&!d[6])    return 2;
        if(!d[2]&&!d[5])    return 3;
        if(!d[3]&&!d[5])    return 5;
    }
    if(sum==6)
    {
        if(!d[4])   return 0;
        if(!d[3])   return 6;
        if(!d[5])   return 9;
    }
    if(sum==7)  return 8;
    return 0;
}

int main(int argc, const char * argv[]) {
    int T;
    scanf("%d",&T);
    while(T--)
    {
        for(int i=0;i<7;i++)    scanf("%s",s[i]);
        printf("%d%d:%d%d\n",cal(0),cal(5),cal(12),cal(17));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值