【多校训练】hdu 6168 Numbers

Problem Description
zk has n numbers  a1,a2,...,an . For each (i,j) satisfying 1≤i<j≤n, zk generates a new number  (ai+aj) . These new numbers could make up a new sequence  b1b2,...,bn(n1)/2 .
LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can't figure out which numbers were in a or b. "I'm angry!", says zk.
Can you help zk find out which n numbers were originally in a?
 

Input
Multiple test cases(not exceed 10).
For each test case:
The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It's guaranteed m can be formed as n(n+1)/2.
The second line contains m numbers, indicating the mixed sequence of a and b.
Each  ai  is in [1,10^9]
 

Output
For each test case, output two lines.
The first line is an integer n, indicating the length of sequence a;
The second line should contain n space-seprated integers  a1,a2,...,an(a1a2...an) . These are numbers in sequence a.
It's guaranteed that there is only one solution for each case.
 

Sample Input
  
  
6 2 2 2 4 4 4 21 1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11
 

Sample Output
  
  
3 2 2 2 6 1 2 3 4 5 6
 

题意:

有n个数,可以两两组合成n(n-1)/2个数。把它们混成一个数组,求出原n个数。

思路:

将b数组排序,取出最小的两项作为a1,a2a1,a2,删除a1,a2,a1+a2a1,a2,a1+a2,再取出最小项作为a3a3,再删除a3,a1+a3,a2+a3a3,a1+a3,a2+a3,再取出最小项作为a4a4,依次列推。


可以用map来维护被删除的数

//
//  main.cpp
//  1008
//
//  Created by zc on 2017/8/22.
//  Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<map>
#define ll long long
using namespace std;
map<ll,int> mp;
const int N=220000;
ll a[N],b[N];

int main(int argc, const char * argv[]) {
    int m,n;
    while(~scanf("%d",&m))
    {
        mp.clear();
        for(int i=0;i<m;i++)    scanf("%lld",&a[i]);
        sort(a,a+m);
        n=(int)sqrt(2*m);
        while(n*(n+1)/2>m)  n--;
        while(n*(n+1)/2<m)  n++;
        int l=0;
        for(int i=0;i<n;i++)
        {
            while(l<m&&mp[a[l]]>0)
            {
                mp[a[l]]--;
                l++;
            }
            b[i]=a[l++];
            for(int j=0;j<i;j++)
            {
                mp[b[i]+b[j]]++;
            }
        }
        printf("%d\n",n);
        for(int i=0;i<n;i++)
        {
            printf("%lld",b[i]);
            if(i==n-1)  printf("\n");
            else printf(" ");
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值