【多校训练】hdu 6085 Rikka with Candies bitset

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

There are  n  children and  m  kinds of candies. The  i th child has  Ai  dollars and the unit price of the  i th kind of candy is  Bi . The amount of each kind is infinity. 

Each child has his favorite candy, so he will buy this kind of candies as much as possible and will not buy any candies of other kinds. For example, if this child has  10 dollars and the unit price of his favorite candy is  4  dollars, then he will buy two candies and go home with  2  dollars left.

Now Yuta has  q  queries, each of them gives a number  k . For each query, Yuta wants to know the number of the pairs  (i,j)(1in,1jm)  which satisfies if the  i th child’s favorite candy is the  j th kind, he will take  k  dollars home.

To reduce the difficulty, Rikka just need to calculate the answer modulo  2 .

But It is still too difficult for Rikka. Can you help her?
 

Input
The first line contains a number  t(1t5) , the number of the testcases. 

For each testcase, the first line contains three numbers  n,m,q(1n,m,q50000)

The second line contains  n  numbers  Ai(1Ai50000)  and the third line contains  m  numbers  Bi(1Bi50000) .

Then the fourth line contains  q  numbers  ki(0ki<maxBi)  , which describes the queries.

It is guaranteed that  AiAj,BiBj  for all  ij .
 

Output
For each query, print a single line with a single  01  digit -- the answer.
 

Sample Input
  
  
1 5 5 5 1 2 3 4 5 1 2 3 4 5 0 1 2 3 4
 

Sample Output
  
  
0 0 0 0 1
 

题意:

两个长度分别为  n,m  的数组  A,B  。有  q  个询问,每个询问给出一个数字  k  ,可以得到使得  AimodBj=k 的种数。求该种数的奇偶性。


思路:

求a%b==k的数量  

->求a-k==b*j的数量

->可以用bitset优化成 ((a>>k)&bn).count(),bn为b的倍数。由于b一定要大于k,所以从大到小枚举。

具体看代码:

//
//  main.cpp
//  1001
//
//  Created by zc on 2017/8/30.
//  Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstring>
#include<cstring>
#include<cmath>
#include<bitset>
#include<algorithm>
using namespace std;
const int N=55000;
bitset<N>a,b,ans,bn;

int main(int argc, const char * argv[]) {
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m,q,t,mmax=0;
        a.reset();b.reset();ans.reset();bn.reset();
        scanf("%d%d%d",&n,&m,&q);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&t);
            a.set(t);
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d",&t);
            b.set(t);
            mmax=max(mmax,t);
        }
        for(int i=mmax;i>=0;i--)
        {
            ans[i]=((a>>i)&bn).count()&1;//a%b==k, b>k  ->  a-k==j*b, b>k   ->  (a>>k)&bn
            if(b[i])
            {
                for(int j=0;j<N;j+=i)    bn.flip(j);
            }
        }
        for(int i=0;i<q;i++)
        {
            scanf("%d",&t);
            if(ans[t])  puts("1");
            else    puts("0");
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值