Faulty Odometer

Faulty Odometer
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9038 Accepted: 5613

Description

You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 3 to the digit 5, always skipping over the digit 4. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15339 and the car travels one mile, odometer reading changes to 15350 (instead of 15340).

Input

Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 4.

Output

Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.

Sample Input

13
15
2003
2005
239
250
1399
1500
999999
0

Sample Output

13: 12
15: 13
2003: 1461
2005: 1462
239: 197
250: 198
1399: 1052
1500: 1053
999999: 531440
 
分析:
因为没有4,所以我们把一个数当做9(10-1)进制来看,因此,在这个输入的9进制中,每一位的数上,9就看作是8,5、6、7、8就当作4、5、6、7来看待,而4就当作0来看待,因此,当我们把这个九进制数转换成十进制数的时候,它就是我们所要求的结果。

源代码:
 
#include <iostream>
using namespace std;

int a[10]={0,1,2,3,0,4,5,6,7,8};
int main()
{
	int m,n,ans,temp;
	while(cin>>n && n)
	{
		ans=0;
		temp=1;
		m=n;
		while(n>0)
		{
			ans+=a[n%10]*temp;
			n/=10;
			temp*=9;
		}
		cout<<m<<": "<<ans<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值