HDU 1233 最小生成树和并查集

还是畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35414    Accepted Submission(s): 15941


Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最小的公路总长度。
 

Sample Input
  
  
3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0
 

Sample Output
  
  
3 5
Hint
Hint
Huge input, scanf is recommended.
 


遇到的问题和思路:

        TAT话说这道题目不难啊,为什么我代码之前WA换了一下位置就AC了,我很无语啊。



prim算法AC的

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>

using namespace std;

const int MAX_N = 120 + 10;
const int inf = 0x3f3f3f3f;
long long n, m, a, b, v;
long long cost[MAX_N][MAX_N];
bool used[MAX_N];
long long mincost[MAX_N];


long long prim(){
    for(int i = 0; i < n; ++i){
        mincost[i] = inf;
        used[i] = false;
    }
    mincost[0] = 0;
    long long res = 0;
    while(true){
        int x = -1;
        for(int i = 0; i < n; i++){//选出当前,价值最小的边所连接的顶点 
            if (!used[i] && (x == -1 || mincost[i] < mincost[x]))x = i;
        }
        if(x == -1)break;
        used[x] = true;
        res += mincost[x];
        for(int i = 0; i < n; i++){
            mincost[i] = min (mincost[i], cost[x][i]);//x所连接的边中的最小的值 
        }    
    }
    return res;
}
void inti(){
    for(int i = 0; i < MAX_N; i++){
        for(int j = 0; j < MAX_N; j++){
            cost[i][j] = inf;
        }
    }
}

int main(){
    while(scanf("%I64d", &n) && n){
        int f = n * (n - 1) / 2;
        inti();
        for(int i = 0; i < f; i++){
            scanf("%I64d%I64d%I64d", &a, &b, &v);
            cost[a-1][b-1] = v;
            cost[b-1][a-1] = v;
        }
        printf("%I64d\n", prim());
    }
    return 0;
}

下面这种代码也是prim,不过不知道为什么,就和上面的位置不一样,就一直WA


#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>

using namespace std;

const int MAX_N = 100 + 10;
const int inf = 23333333;
int n, m, a, b, v;
int cost[MAX_N][MAX_N];
bool used[MAX_N];
int mincost[MAX_N];


int prim(){
    mincost[0] = 0;
    int res = 0;
    while(true){
        int v = -1;
        for(int i = 0; i < n; i++){//选出当前,价值最小的边所连接的顶点 
            if (!used[i] && (v == -1 || mincost[i] < mincost[v]))v = i;
        }
        if(v == -1)break;
        used[v] = true;
        res += mincost[v];
        for(int i = 0; i < n; i++){
            mincost[i] = min (mincost[i], cost[v][i]);//v所连接的边中的最小的值 
        }    
    }
    return res;
}
void inti(){
    for(int i = 0; i < n; i++){
        for(int j = 0; j < n; j++){
            cost[i][j] = inf;
        }
        used[i] = false;
        mincost[i] = inf;
    }
}

int main(){
    while(scanf("%d", &n) && n){
        int f = n * (n - 1) / 2;
        inti();
        for(int i = 0; i < f; i++){
            scanf("%d%d%d", &a, &b, &v);
            cost[a-1][b-1] = v;//如果再加上一句cost[b-1][a-1] = v就是AC了,千万别忘了加
        }
        printf("%d\n", prim());
    }
    return 0;
}

kruskal算法:


#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>

using namespace std;

typedef long long ll;
const ll MAX_N = 100 + 20;
ll n, f, par[MAX_N + 10], rank1[MAX_N + 10];
struct edge{
    ll from, to, cost;
};
edge es[MAX_N * MAX_N + 10];

bool cmp(const edge &e1, const edge &e2){
    return e1.cost < e2.cost;
}

void init(){
    for(int i = 1; i <= n; i++){
        par[i] = i;
        rank1[i] = 0;
    }
}

int find(int x){
    if(par[x] == x) return x;
    return par[x] = find(par[x]);
}

void unite(int x, int y){
    x = find(x);
    y = find(y);
    if(x == y)return ;
    if(rank1[x] > rank1[y]){
        par[y] = x;
    }
    else {
        par[x] = y;
        if(rank1[x] == rank1[y])rank1[y]++;
    }
}


bool same(int a, int b){
    return find(a) == find(b);
}

void kruskal(){
    sort(es + 1, es + f + 1, cmp);
    init();
    ll res = 0;
    for(int i = 1; i <= f; i++){
        edge e = es[i];
        if(!same(e.from, e.to)){
            unite(e.from, e.to);
            res += e.cost;
        }
    }
    printf("%I64d\n", res);
}

int main(){
    while(scanf("%I64d", &n) && n){
        f = n * (n - 1) / 2;
        for(int i = 1; i <= f; i++){
            scanf("%I64d%I64d%I64d", &es[i].from, &es[i].to, &es[i].cost);
        }
        kruskal();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值