ZCMU-1517-A Sorting Problem

1517: A Sorting Problem

Time Limit: 2 Sec   Memory Limit: 32 MB
Submit: 165   Solved: 55
[ Submit][ Status][ Web Board]

Description

There was a boy called ZDD, and he loved a girl who name was SZD. They had led a happy life for a long time. Yesterday, ZDD learnt an algorithm: Bubble sort. Bubble sort will compare each pair of adjacent items and swap them if they are in the wrong order. The process repeats until no swap is needed.

Today, ZDD comes up with a new algorithm and names it SZD Sorting.

There are many rounds in SZD Sorting. For each round, ZDD chooses a number, and keeps swapping it with its next number while the next number is less than it. For example, if the sequence is “1 4 2 3 5”, and ZDD chooses “4”, he will get “1 3 2 4 5” after this round. SZD Sorting is similar to Bubble sort, but it’s a randomized algorithm because ZDD will choose a random number at the beginning of each round. ZDD wants to know that, for a given sequence, how many rounds are needed to sort this sequence in the best situation. In other words, you should answer the minimal number of rounds needed to sort the sequence into ascending order. To simplify the problem, ZDD promises that the elements of the sequence are all different.

Input

         The first line contains only one integer T(T<=200), which indicates the number of test cases.

For each test case, the first line contains an integer N(1<=N<=106).

The second line contains N integers ai(1<=ai<=109), denoting the sequence ZDD gives you.

Output

For each test case, you should print the answer in one line.

Sample Input

2
5
5 4 3 2 1
5
5 1 2 3 4

Sample Output

4
1



HINT

In the second sample, we choose “5” so that after the first round, sequence becomes “1 2 3 4 5”, and the algorithm completes.


【解析】
这道题的意思就是让我们输出需要排序的个数有多少个,比如说样例里面的序列是5 4 3 2 1,这样的话5需要排序,因为5后面有小于它的数,而4也需要排序,因为4后面有小于它的数,这样一直下去发现前面四个数其实都需要排序,因为排序是只改变大的数往后面,我们判断的是后面比它小的数所以之前不断的把大的数往后面是不影响我们比较 毕竟大的数一直都往后面小的数是不变的。所以我们不需要真的去操作,直接判断次数就好了。模拟是会超时的。
#include<iostream>
#include<cstring>
#include<algorithm>
#include<string>
#include<cstdio>
using namespace std;
int a[1000001];
int main()
{
    int t,n,i,j,temp;
    int count1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        count1=0;
        memset(a,0,sizeof(a));
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(i=0;i<n;i++)
        {
            for(j=i+1;j<n;j++)
            {
                if(a[j]<a[i])
                {
                    count1++;//后面的数比前面的数大就表示需要排序
                    break;
                }
            }
        }
        printf("%d\n",count1);
    }
    return 0;
}
### 回答1: zcmu 1093 简单计算器是一道编程题目,要求实现一个简单的计算器,能够进行加、减、乘、除四种基本运算。该题目主要考察编程基础能力和算法思维能力,需要熟练掌握基本的运算符和控制语句,能够设计合理的算法实现计算器功能。 ### 回答2: zcmu 1093 简单计算器是一种基于计算机技术的工具,用于进行基本算术运算,如加减乘除等。它能够简化我们在日常生活中的计算工作,提高计算效率,减少出错率。 使用zcmu 1093 简单计算器非常简单,只需输入需要计算的数字和符号,就能够得到计算结果。它可以进行多个数字之间的复杂运算,同时还支持小数、百分数、平方根等复杂运算。另外,zcmu 1093 简单计算器还可以存储中间计算结果,方便我们进行多步计算或调整计算过程。 除了日常的计算工作,zcmu 1093 简单计算器还可用于科学计算、工程设计等领域。许多专业软件都是基于简单计算器原理设计的,它们具有更高的计算精度和更复杂的运算能力,能够支持更高级别的科学计算和技术分析。 总之,zcmu 1093 简单计算器在日常生活中有着广泛的应用,它使我们的计算工作变得更加高效、准确。并且,随着科技的不断发展,这种计算工具也在不断地更新和改进,为我们的计算工作提供更加便捷、多样化的选择。 ### 回答3: ZCMU 1093 简单计算器是一道基础的算法题目,需要实现一个简单的计算器程序,支持加、减、乘、除四种基本运算,可以对两个整数进行运算并输出结果。 要实现这道题目,首先需要根据输入的运算符来判断应该进行的运算类型,并根据运算符的不同,执行不同的计算操作。同时,应注意除数不能为零的情况,避免程序出现异常。 在编写程序的过程中,可以使用 switch case 语句来判断不同的运算类型,并执行相应的计算操作。同时,为了能有效地判断输入的运算符,可以使用输入字符串的方式进行处理,提取出运算符进行比较。 此外,在程序中还需要进行合法性判断,确保输入的数字均为整数且在合理的范围内,以避免程序运行出现异常情况。同时,还需要考虑输入格式的问题,应确保输入的数字和运算符符合题目要求。 综上所述,ZCMU 1093 简单计算器是一道基础的算法题目,需要实现一个简单的计算器程序,支持加、减、乘、除四种基本运算,注意程序的合法性判断和输入格式的处理,能够熟练地运用 switch case 等语句完成程序的编写。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值