POJ-3273-Monthly Expense

3 篇文章 0 订阅
Monthly Expense
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 22175 Accepted: 8681

Description

Farmer John is an astounding(令人震惊的) accounting wizard(男巫) and has realized he might run out of money to run the farm. He has already calculated(计算) and recorded the exact amount(数量) of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget(预算) for a sequential(连续的) set of exactly M (1 ≤ M ≤ Nfiscal(会计的) periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive(连贯的)days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize(使减到最少) the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated  integers (整数)N and  M
Lines 2.. N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John  schedules (时间表) the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger  minimum (最小的) monthly limit.

给出农夫在n天中每天的花费,要求把这n天分作m组,每组的天数必然是连续的,要求分得各组的花费之和应该尽可能地小,最后输出各组花费之和中的最大值
二分
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
using namespace std;

int main()
{
    int n, m, low, high, mid, MAX = 0, a[100010], sum = 0, ans;
    scanf("%d%d", &n, &m);
    for(int i = 0;i<n;++i)
    {
        scanf("%d", &a[i]);
        sum+=a[i];
        if(MAX<a[i])MAX= a[i];
    }
    high = sum;
    low = MAX;
    while(low<=high)
    {
        mid = (low+high)/2;
        ans = 1;
        sum = 0;
        for(int i = 0; i<n;++i)
        {
            sum+=a[i];
            if(sum>mid)
            {
                sum = a[i];
                ans++;
            }
        }
        if(ans<=m)
        {
            high = mid-1;
            MAX = mid;
        }
        else
            low = mid+1;
    }
    printf("%d\n", MAX);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值