Balanced Lineup

第一个手敲的线段树代码,以前一直用板子QAQ

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <vector>
#include <math.h>
#include <algorithm>
#include <map>
#include <stdlib.h>
#include <queue>
#include <functional>

using namespace std;

const int MAX = 5e4+10;
const double eps = 1e-8;
const double PI = acos(-1.0);
struct node
{
    int minn, maxx;
}lxt[MAX*6];
int a[MAX];
int n, q, r, l;
void build(int l, int r, int pos)
{
    if(l==r)
    {
        scanf("%d", &lxt[pos].minn);
        lxt[pos].maxx = lxt[pos].minn;
    }
    else
    {
        build(l, (l+r)/2, pos*2);
        build((l+r)/2+1, r, pos*2+1);
        lxt[pos].maxx = max(lxt[pos*2+1].maxx, lxt[pos*2].maxx);
        lxt[pos].minn = min(lxt[pos*2+1].minn, lxt[pos*2].minn);
    }
    //printf("%d %d %d %d \n", l, r, lxt[pos].maxx, lxt[pos].minn);
}
int check1(int l, int r, int ll, int rr, int pos)
{
    if(ll==l&&rr==r)return lxt[pos].maxx;
    else
    {
        int mid = (ll+rr)/2;
        if(r<=rr&&l>mid)return check1(l,r,mid+1, rr, pos*2+1);
        else if(r<=mid&&l>=ll)return check1(l,r,ll,mid,pos*2);
        else
        {
            return max(check1(l, mid, ll, mid, pos*2),check1(mid+1, r, mid+1, rr, pos*2+1));
        }
    }
}
int check2(int l, int r, int ll, int rr, int pos)
{
    if(ll==l&&rr==r)return lxt[pos].minn;
    else
    {
        int mid = (ll+rr)/2;
        if(r<=rr&&l>mid)return check2(l,r,mid+1, rr, pos*2+1);
        else if(r<=mid&&l>=ll)return check2(l,r,ll,mid,pos*2);
        else
        {
            return min(check2(l, mid, ll, mid, pos*2),check2(mid+1, r, mid+1, rr, pos*2+1));
        }
    }
}
int main()
{
    while(~scanf("%d%d", &n, &q))
    {
        build(1, n, 1);
        //for(int i =1; i<=50; ++i)
        //printf("%d %d\n", lxt[i].maxx, lxt[i].minn);
        while(q--)
        {
            scanf("%d%d", &l, &r);
            if(l>r)swap(l,r);
            printf("%d\n", check1(l,r,1,n,1)-check2(l,r,1,n,1));
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值