2017 Multi-University Training Contest - Team 6 Inversion

Problem Description
We define the distance of two strings A and B with same length n is
disA,B=i=0n1|AiBn1i|
The difference between the two characters is defined as the difference in ASCII.
You should find the maximum length of two non-overlapping substrings in given string S, and the distance between them are less then or equal to m.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integers m : the limit distance of substring.
Then a string S follow.

Limits
T100
0m5000
Each character in the string is lowercase letter,  2|S|5000
|S|20000
 

Output
For each test case output one interge denotes the answer : the maximum length of the substring.
 

Sample Input
  
  
1 5 abcdefedcb
 

Sample Output
  
  
5
Hint
[0, 4] abcde [5, 9] fedcb The distance between them is abs('a' - 'b') + abs('b' - 'c') + abs('c' - 'd') + abs('d' - 'e') + abs('e' - 'f') = 5

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <cmath>
#include <stdlib.h>
using namespace std;
typedef long long LL;
const LL MAX = 5000+10;
const LL mod = 7654321; 
const double eps = 1e-8;
const double PI = acos(-1.0);
#define zero(x) (((x)>0?(x):(-x))<eps)
int ans, m, len;
char s[MAX];
void solve(int a, int b){
    int l = 0, r = 0, sum = 0;
    while(a+r<b-r){
        sum+=abs(s[a+r]-s[b-r]);
        r++;
        if(b-l-a-l+1<=ans*2)break;
        //printf("%d %d\n", l, r);
        //printf("%d %d %d %d\n", a+l, a+r, b-r, b-l);
        while(sum>m&&r>l){
            sum-=abs(s[a+l]-s[b-l]);
            l++;
        }
        if(ans<r-l)ans = r-l;
    }
}
int main() {
    int t;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &m);
        scanf("%s", s);
        len = strlen(s);
        ans = 0;
        for(int i = 1; i<len; ++i){
            solve(0, i);
        }
        for(int i = 0; i<len-1; ++i){
            solve(i,len-1);
        }
        printf("%d\n", ans);
    }
    return 0;
}   




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值