2017 Multi-University Training Contest - Team 6:1003&hdu6098、Inversion

题目:

Problem Description
Give an array A, the index starts from 1.
Now we want to know Bi=maxijAj , i2 .
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integer n : the size of array A.
Next one line contains n integers, separated by space, ith number is Ai .

Limits
T20
2n100000
1Ai1000000000
n700000
 

Output
For each test case output one line contains n-1 integers, separated by space, ith number is Bi+1 .
 

Sample Input
  
  
2 4 1 2 3 4 4 1 4 2 3
 

Sample Output
  
  
3 4 3 2 4 4
题意:求出B_i+1数组,i从2开始,max{A_j}(i%j!=0)

思路:写个结构体,用x记录A的值,pos记录在A中的位置,排序,从大到小找符合条件的,输出。。。签到题

code:

#include<bits/stdc++.h>
using namespace std;
int a[100005];
struct node{
        int x,pos;
}b[100005];
int cmp(node a,node b)
{
        if(a.x<b.x) return 1;
        return 0;
}
int main(){
        int t,n,i,j;
        scanf("%d",&t);
        while(t--){
                scanf("%d",&n);
                for(i=1;i<=n;i++){
                        scanf("%d",&a[i]);
                        b[i].x=a[i];
                        b[i].pos=i;
                }
                sort(b+1,b+n+1,cmp);
                for(i=2;i<=n;i++){
                        j=n;
                        while(b[j].pos%i==0) j--;
                        if(i!=n) printf("%d ",b[j].x);
                        else printf("%d\n",b[j].x);
                }
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值