[AIZU ONLINE JUDGE] 计算几何 CGL_2_C

Cross Point

For given two segments s1 and s2, print the coordinate of the cross point of them.

s1 is formed by end points p0 and p1, and s2 is formed by end points p2 and p3.

Input

The entire input looks like:

q (the number of queries)
1st query
2nd query
...
qth query

Each query consists of integer coordinates of end points of s1 and s2 in the following format:

xp0 yp0 xp1 yp1 xp2 yp2 xp3 yp3

Output

For each query, print the coordinate of the cross point. The output values should be in a decimal fraction with an error less than 0.00000001.

Constraints

  • 1 ≤ q ≤ 1000
  • -10000 ≤ xpi, ypi ≤ 10000
  • p0 ≠ p1 and p2 ≠ p3.
  • The given segments have a cross point and are not in parallel.

Sample Input

3
0 0 2 0 1 1 1 -1
0 0 1 1 0 1 1 0
0 0 1 1 1 0 0 1

Sample Output

1.0000000000 0.0000000000
0.5000000000 0.5000000000
0.5000000000 0.5000000000

题目大意:

求出给定两条线段的交点

题解:

全是模板,先判断两条线段是否相交,再求出线段的交点


#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>

using namespace std;

const double eps = 1e-10;

int sign(double x)
{
	if (fabs(x) < eps)return 0;
	if (x > 0)return 1;
	return -1;
}

struct Point
{
	double x, y;

	Point(double x = 0, double y = 0) :x(x), y(y) { }

	Point operator- (Point& t)
	{
		return Point(x - t.x, y - t.y);
	}

	Point operator+ (Point& t)
	{
		return Point(x + t.x, y + t.y);
	}

	Point operator* (const double& t)
	{
		return Point(t * x, t * y);
	}
};

typedef Point Vector;

struct Line
{
	Point p;
	Vector v;

	Line(Point p, Vector v) : p(p), v(v) { }
};

int m;

double dot(Vector A, Vector B)
{
	return A.x * B.x + A.y * B.y;
}

double cross(Vector A, Vector B)
{
	return A.x * B.y - A.y * B.x;
}

bool OnSegment(Point p, Point a1, Point a2)
{
	return sign(cross(a1 - p, a2 - p)) == 0 && sign(dot(a1 - p, a2 - p)) <= 0;
}

bool Segment_proper_intersection(Point a1, Point a2, Point b1, Point b2)
{
	double c1 = cross(a2 - a1, b1 - a1), c2 = cross(a2 - a1, b2 - a1);
	double c3 = cross(b2 - b1, a1 - b1), c4 = cross(b2 - b1, a2 - b1);

	//cout << c1 << ' ' << c2 << " " << c3 << " " << c4 << endl;

	//if判断控制是否允许线段在端点处相交,根据需要添加
	if (!sign(c1) || !sign(c2) || !sign(c3) || !sign(c4)) {
		bool f1 = OnSegment(b1, a1, a2);
		bool f2 = OnSegment(b2, a1, a2);
		bool f3 = OnSegment(a1, b1, b2);
		bool f4 = OnSegment(a2, b1, b2);

		//cout << f1 << ' ' << f2 << ' ' << f3 << ' ' << f4 << endl;

		bool f = (f1 | f2 | f3 | f4);
		return f;
	}
	return (sign(c1) * sign(c2) < 0 && sign(c3) * sign(c4) < 0);

}
Point Get_line_intersection(Point P, Vector v, Point Q, Vector w)
{
	Vector u = P - Q;
	double t = cross(w, u) / cross(v, w);
	Point b = v * t;
	return P + b;
}

int main()
{
	cin >> m;
	while (m--)
	{
		Point A, B, C, D;
		cin >> A.x >> A.y >> B.x >> B.y >> C.x >> C.y >> D.x >> D.y;

		if (Segment_proper_intersection(A, B, C, D))
		{
			Vector v1 = B - A, v2 = D - C;
			Point x = Get_line_intersection(A, v1, C, v2);

			printf("%.10lf %.10lf\n", x.x, x.y);
			cout << endl;
		}
	}

	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值