Power Strings POJ - 2406(求一串字符串中有多少个循环节)

题意:

有一串字符串,问求出有多少个循环节连续重复组成,即可以用KMP直接求出循环节有多少个字符组成。答案就是l/next[l](刚开始理解错题意,认为是找出最多的重复子串)

题目

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

思路

1.即可以用KMP直接求出循环节有多少个字符组成。答案就是l/next[l]。
2.若不连续则循环节个数为一。

ac代码

#include <cstdio>
#include <cstring>
#include <algorithm>
const  int M=1e6+10;
int next[M] ;
char str[M] ;
void getnext(int l)
{
    int j = 0 , k = -1 ;
    next[0] = -1 ;
    while(j < l)
    {
        if( k == -1 || str[j] == str[k] )
            next[++j] =++k ;
        else
            k = next[k] ;
    }
}
int main()
{
    int l , m ;
    while(~scanf("%s", str)&&str[0]!= '.')
    {
        l = strlen(str);
        getnext(l) ;
        m = next[l];
        if( l % (l-next[l]) != 0 )
            printf("1\n");
        else
        {
            int k= l/( l-next[l]);
            printf("%d\n",k);
        }
        memset(str,0,sizeof(str));
    }
    return 0;
}/**题目要求有循环节重复连续,即整个串是用循环节组成的*/

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值