Assign the task HDU - 3974(线段树+dfs建树+单点查询+区间修改)

题意:

染色问题:给一个固定结构的树,现在有两个操作:
(1) y 将结点x及其所有后代结点染成颜色y;
(2)查询结点x当前的颜色。
其实就是区间染色问题,不过需要dfs预处理,

题目:

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody’s boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

“C x” which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1
5
4 3
3 2
1 3
5 2
5
C 3
T 2 1
C 3
T 3 2
C 3

Sample Output

Case #1:
-1
1
2

分析:

1.由于题目给的是一个固定的树,所以我们需要对它进行处理,使之成为我们好处理的区间问题。
2.关于预处理我采用的是先用vector容器进行存边,之后dfs,用两个数组分别存储以某点为“”祖宗节点“”的区间起始(类似时间戳的思想,将某个点的编号)
3.预处理之后就是线段树模板啦嘿嘿,这个没啥好说的,这里不再赘述: 区间修改+单点查询

AC代码:

#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
using namespace std;
const int M=5e4+10;
int t,n,m,ans,a,b,k;
vector<int>ve[M];
int L[M],R[M],dp[M<<2],lazy[M<<2];
bool vis[M];
char s[5];
void dfs(int x)
{
    L[x]=++ans;
    for(int i=0; i<ve[x].size(); i++)
        dfs(ve[x][i]);
    R[x]=ans;
}
void pushdown(int x)
{
    if(lazy[x])
    {
        lazy[x<<1]=lazy[x<<1|1]=lazy[x];
        dp[x<<1]=dp[x<<1|1]=dp[x];
        lazy[x]=0;
    }
}
void update(int mi,int ma,int l,int r,int x,int value)
{
    if(l>=mi&&r<=ma)
    {
        dp[x]=lazy[x]=value;
        return;
    }
    pushdown(x);
    int mid=(l+r)>>1;
    if(mid>=mi)
        update(mi,ma,l,mid,x<<1,value);
    if(mid<ma)
        update(mi,ma,mid+1,r,x<<1|1,value);
}
int query(int now,int l,int r,int x)//单点修改
{
    if(l==r)
        return dp[x];
    pushdown(x);
    int mid=(l+r)>>1;
    if(mid>=now)
        return query(now,l,mid,x<<1);
    else
        return query(now,mid+1,r,x<<1|1);
}
int main()
{
    scanf("%d",&t);
    k=0;
    while(t--)
    {
        ans=0;
        memset(dp,-1,sizeof(dp));
        memset(lazy,0,sizeof(lazy));
        memset(vis,false,sizeof(vis));
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            ve[i].clear();
        for(int i=0; i<n-1; i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            ve[v].push_back(u);//接下来的N-1行每行包含两个整数u和v,这表示雇员v是雇员u(1 <= u,v <= N)的直接老板。
            vis[u]=true;
        }
        for(int i=1; i<=n; i++)
            if(!vis[i])
                dfs(i);
        scanf("%d",&m);
        printf("Case #%d:\n",++k);
        while(m--)
        {
            scanf("%s",s);
            if(s[0]=='C')
            {
                scanf("%d",&a);
                printf("%d\n",query(L[a],1,ans,1));
            }
            else
            {
                scanf("%d%d",&a,&b);
                update(L[a],R[a],1,ans,1,b);
            }
        }
    }
    return 0;
}

备战ing,题目分析简略,见谅,转载请注明出处。。。。。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值