Maximum Sum UVA - 108(连续子序列最大和—>变形之子矩阵最大和)

题目大意:给出 n*n 的矩阵,找每隔数字之和最大的子矩阵,输出最大和。 
解题思路:枚举矩阵左上和右下的坐标,分别合并子矩阵的每列,使得二维转化为一维,然后利用连续子序列最大和去做就行。

Time limit    3000 ms

题目描述:

A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem.

Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the subrectangle with the largest sum is referred to as the maximal sub-rectangle.

A sub-rectangle is any contiguous sub-array of size 1 × 1 or greater located within the whole array. As an example, the maximal sub-rectangle of the array:

                                  0     −2     −7       0

                                  9       2     −6       2

                                −4       1     −4       1

                                −1       8        0     −2

is in the lower-left-hand corner:

                                  9      2

                                −4      1

                                −1      8

and has the sum of 15.

Input

The input consists of an N × N array of integers.

The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by N2 integers separated by white-space (newlines and spaces). These N2 integers make up the array in row-major order (i.e., all numbers on the first row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [−127, 127].

Output

The output is the sum of the maximal sub-rectangle.

Sample Input

   4

   0     −2     −7       0

   9       2     −6       2

 −4       1     −4       1

 −1       8        0     −2

Sample Output

15

题目理解:即在矩形中得到一个小矩形中总和最大数,即遍历长宽高

#include<iostream>
#include<string.h>
#define inf 0x3f3f3f3f
using namespace std;
int n,dp[1010][1010],ans;
int main()
{
    while(cin>>n)
    {
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                cin>>dp[i][j];
        ans=dp[0][0];
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                if(j>=i)
                {
                    int sum=0;
                    for(int k=0; k<n; k++)
                    {
                        int step=0;
                        for(int u=i; u<=j; u++)
                        {
                            step+=dp[u][k];
                        }
                        sum+=step;
                        if(sum>ans)
                            ans=sum;
                        if(sum<0)
                            sum=0;
                    }
                }
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值