UVA - 108 Maximum Sum

is in the lower-left-hand corner:is in the lower-left-hand corner:A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem.

Givena2-dimensionalarrayofpositiveandnegativeintegers,findthesub-rectanglewiththelargest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the subrectangle with the largest sum is referred to as the maximal sub-rectangle. A sub-rectangle is any contiguous sub-array of size 1×1 or greater located within the whole array. As an example, the maximal sub-rectangle of the array:

is in the lower-left-hand corner:

9 2

−4 1

−1 8

and has the sum of 15.

Input

The input consists of an N ×N array of integers. The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by N2 integers separated by white-space (newlines and spaces). These N2 integersmakeupthearrayinrow-majororder(i.e., allnumbersonthefirstrow,left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [−127,127].

Output

The output is the sum of the maximal sub-rectangle.

Sample Input

4

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

Sample Output

15

题解:

给你一个nXn的矩阵,求这个矩阵的子矩阵的和的最大值。

将每两层合并为一层,接着枚举所有层数的情况,找出最大值

贴代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        int i,j,k,mp[110][110];
        memset(mp,0,sizeof(mp));
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
                scanf("%d",&mp[i][j]);
        int ans=mp[1][1],sum;
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
                mp[i][j]+=mp[i-1][j];//两行合并为一行
        for(i=1; i<=n; i++)
            for(j=i; j<=n; j++)//遍历所有情况
            {
                sum=0;
                for(k=1; k<=n; k++)
                {
                    if(sum<0)
                        sum=0;
                    else if(j>i)
                        sum+=mp[j][k]-mp[i][k];//相减即为此处最初的值
                    if(sum>ans&&sum>0)
                        ans=sum;
                }
            }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值