Pearls POJ - 1260(区间记忆化搜索)

题意: n件物品,给出数量和价格,(注意数量和价格都是升序给出的这个是能DP的关键),要买掉所以商品 对于每类物品,所需要的价格是(a[i]+10)*p[i] ,即要多买10件,也可以把价格低的物品合并到高价格的物品那 即 (a[j]+a[i]+10)*p[j];代表把价格为i的物品合并到j上。设dp[i]为买完第i类物品的最优解      dp[i]=min(dp[i],dp[j]+(a[j+1]+a[j+2]+a[i]+10)*p[i]);
即对于第i类物品来说,它最多合并前面的i-1种物品,而且因为物品数目和价格都是升序的,所以可以证明只要 第j类物品能合并,那么再往后就都能合并,因为第j类物品合并省出的钱可以表示为 a[j]*p[i]-(a[j]+10)*p[j] ;如果上式小于0,说明可以合并j,而当j增大,数目和价格都增大,所以只会比j的时候更加省钱,即更能替换。
综上,有两种办法:从前往后推,状态转移方程上面以给出。(主函数)

Time limit   1000 ms

Memory limit     10000 kB

OS     Linux

Source     Northwestern Europe 2002

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class. 
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl. 
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the 
prices remain the same. 
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro. 
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program. 

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one.

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000). 
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers. 

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list. 

Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12

Sample Output

330
1344从后往前推。因为对于最后一种状态n,要从前面的n-1种状态中倒着连续合并。(开函数)如下
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int n,dp[10010];
struct node
{
    int a,b,u,v;
} s[10010];
int dfs(int step)
{
    if(step<1)
        return 0;
    if(dp[step]!=-1)
        return dp[step];
    if(step==1)
        return dp[step]=s[step].u;
    dp[step]=s[step].u+dfs(step-1);
    for(int i=step-1; i>=1; i--)
        dp[step]=min(dp[step],(s[step].v-s[i-1].v+10)*s[step].b+dfs(i-1));
    return dp[step];
}
int main()
{
    int m;
    cin>>m;
    while (m--)
    {
        cin>>n;
        s[0].v=0;
        memset(dp,-1,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            cin>>s[i].a>>s[i].b;
            s[i].u=(s[i].a+10)*s[i].b;
            s[i].v=s[i-1].v+s[i].a;
        }
        cout<<dfs(n)<<endl;
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值