Cheapest Palindrome POJ - 3280(动态规划*)

题意: 
给出一个字符串,要求将其修改成一个回文字符串,给出修改某种字母(添加或删除)的价值,求最小使其成为回文字符串的价值。 
题解: 
感觉是求最长回文子序列的变形,然而刚开始想着用类似于求最长回文子序列的方法,将字符串反转后与原字符串匹配最长公共子序列,在匹配的过程中来进行dp转移,但发现这样不行,因此还是借鉴了网上的方法用dp[i][j]表示处理完区间将i~j之间的字符串变为回文字符串的最小代价,那么很明显有转移方程

Time limit     2000 ms

Memory limit     65536 kB

OS      Linux

Source      USACO 2007 Open Gold

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

题意:有n种字符,组成长为m的串,分别给出字符增加和删除操作 的代价,求把原字符串变成回文串的最小代价

解题思路:区间dp.dp[i][j]表示从区间i到j是一个回文串的最小代价 ,状态转移方程是:如果s[i]=s[j],dp[i][j]=dp[i+1][j-1];否则 dp[i][j]=min(dp[i][j],dp[i+1][j]+min(add[s[i]-'a'],del[s[i]-'a']))), dp[i][j]=min(dp[i][j],dp[i][j-1]+min(add[s[j]-'a'],del[s[j]-'a'])). 区间dp就是将一个区间划分成很多个小区间进行求解

还有一点就是其实虽然给出的删除和修改是两个费用,但实际上每次修改时添加和删除的效果是一样的,因此每次都一定会取其中最小的费用,新开一个数组存起来就不用每次比较了。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
using namespace std;

#define INF 0x3f3f3f3f
const int maxn=30;
const int maxm=2000+5;
int n,m;
string s;
int add[maxn],del[maxn];
int dp[maxm][maxm];
void solve()
{
    int ans=0;
    for(int i=m-1;i>=0;i--)
    {
        dp[i][i]=0;
        for(int j=i+1;j<m;j++)
        {
            dp[i][j]=INF;
            if(s[i]==s[j])
                dp[i][j]=dp[i+1][j-1];
            else
            {
                dp[i][j]=min(dp[i][j],dp[i+1][j]+min(add[s[i]-'a'],del[s[i]-'a']));
                dp[i][j]=min(dp[i][j],dp[i][j-1]+min(add[s[j]-'a'],del[s[j]-'a']));
            }
        }
    }
    printf("%d\n",dp[0][m-1]);
}
int main()
{
    while(cin>>n>>m)
    {
        cin>>s;
        char ch;
        int a,b;
        for(int i=0;i<n;i++)
        {
            cin>>ch>>a>>b;
            add[ch-'a']=a;
            del[ch-'a']=b;
        }
        solve();
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值