Aladdin and the Flying Carpet (素数打表+正整数的唯一分解定理,找因数对)

 

题目大意:给两个数a,b,求满足c*d==a且c>=b且d>=b的c,d二元组对数,(c,d)和(d,c)属于同一种情况 题目分析:根据唯一分解定理先将a唯一分解,则a的所有正约数的个数为ans = (1 + a1) * (1 + a2) *...(1 + an) 因为题目说了不会存在c==d的情况,因此ans要除2,去掉重复情况。[care] 然后枚举小于b的a的约数,拿ans减掉就可以了

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

算数基本原理:任何一个大于1的自然数,都可以唯一分解成有限个质数的乘积 N=p1^a1*p2^a2.....pn^an,这里p1<p2<...<pn均为质数,其诸指数是正整数。 定理应用:(1)一个大于1的正整数N,如果它的标准分解式为:N=p1^a1*p2^a2.....pn^an, 那么它的正因数个数为f(n)=(1+a1)(1+a2).....(1+an)。

AC代码分步详解

#include<iostream>
#include<string.h>
#include<math.h>
typedef long long ll;
#include<stdio.h>
using namespace std;
#define M 1000010
int dp[M];
int book[M];
int t,k;
ll m,n;
void dfs()
{
    k=0;
    memset(dp,0,sizeof(dp));
    memset(book,0,sizeof(book));
    for(int i=2; i<M; i++)/**因为任何一个整数都可以由一个素数经过乘法运算得到,故可通过素数打表的方式求得某数的唯一分解(得到幂次最大)*/
        if(!book[i])
        {
            dp[k++]=i;/*记录素数*/
            for(int j=2*i; j<M; j+=i)
                book[j]=1;
        }
}
int main()
{
    cin>>t;
    int tt=1;
    dfs();/*最好放在外面*/
    while(t--)
    {
        cin>>m>>n;
        ll ans=1;/**定义为 long long 型,否则导致错误答案*/
        ll mm=m;
        if(n>sqrt(m))
            ans=0;
        else
        {
            for(int i=0; i<k&&2*dp[i]<m ; i++) /**care:remember停止条件为i<k&&2*dp[i]<=m,缺一不可*/
            {
                if(m%dp[i]==0)
                {
                    int a=0;
                    while(m%dp[i]==0)
                    {
                        m/=dp[i];/**唯一分解定理:直接对m的值进行操作,得到x=a1^b1*a2^b2.....an^bn*/
                        a++;
                    }
                    ans=ans*(a+1);/**a的所有正约数的个数为ans = (1 + a1) * (1 + a2) *...(1 + an)*/
                }
                if(m==1)
                    break;
            }
            if(m>1)/**for循环,先判断,导致停止,故对最后出现的一个素数的情况判断*2*/
                ans*=2;
            ans/=2;///因为题目说了不会存在c==d的情况,因此ans要除2,去掉重复情况。
            int b=0;
            for(ll i=1; i<n; i++)/**i=1,我的理解是前面由唯一分解定理求因数对个数时,出现了1*m的情况(当所有素数都为1时,该情况出现),此时减去*/
                if(mm%i==0)/**care m的值在上面操作中发生改变,故需要开变量存储m值*/
                    b++;
            ans-=b;/**题目要求,不出现小于n的因数对,找出减去即可*/
        }
        printf("Case %d: %lld\n",tt++,ans);
    }
    return 0;
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值