素数筛选+唯一分解定律-找因数

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

给出矩形面积a,和组成该矩形的边的最小值b,问这种面积为a的矩形有几种,这道题运用了唯一分解定理和素数筛选,链接https://mp.csdn.net/console/editor/html/105450329

代码如下

Select Code

#include<stdio.h>
#include<string.h>
long long x[1000010],v[1000010],k,n=1000010;
void f()
{
    memset(x,1,sizeof(x));//最后x[i]是1的为素数
    long long i,j;
    k=0;
    x[1]=0;//1不是素数
    for(i=2;i<n;i++)
    {
        if(x[i])//如果已经标记为0了,就代表这个不是素数,没有必要再向下进行
        {
            v[k++]=i;
            for(j=2;i*j<=n;j++)
                x[i*j]=0;//这个数的倍数都不是素数
        }
    }
    //printf("%lld**\n",v[5]);
}
long long tt(long long aa)
{
    long long i,s=1;
    for(i=0;i<k&&v[i]<aa;i++)//v[i]<aa,数的范围只求到aa;
    {
            long long p=0;
            while(aa%v[i]==0)
            {
                p++;
                aa=aa/v[i];
            }
            s*=(1+p);//唯一分解定律,s为因子个数
    }
    if(aa>1)
        s*=2;
    return s;
}
int main()
{
    f();
    long long t,h=0;
    scanf("%lld",&t);
    while(t--)
    {
        h++;
        long long a,b,num,i;
        scanf("%lld%lld",&a,&b);
        if(a<b*b)
            printf("Case %lld: 0\n",h);
        else
        {
            num=tt(a)/2;
            //printf("%lld**",num);
            for(i=1;i<b;i++)
            {
                if(a%i==0)
                    num--;//小于b的不满足题意
            }
            printf("Case %lld: %lld\n",h,num);
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值