PAT 甲级 1059. Prime Factors (25)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <stack>
#include <queue>
using namespace std;
vector<int> prime(500000, 1);
int main() {
	for (int i = 2; i*i < 500000; i++)
		for (int j = 2; j*i < 500000; j++)
			prime[j*i] = 0; //建立素数表
	long int a;
	scanf("%ld", &a);
	printf("%ld=", a);
	if (a == 1)printf("1");
	bool state = false;
	for (int i = 2; a >= 2; i++) {
		int cnt = 0, flag = 0;
		while (prime[i] == 1 && a%i == 0) {
			cnt++;
			a = a / i;
			flag = 1;
		}
		if (flag) {
			if (state) printf("*");
			printf("%d", i);
			state = true;
		}
		if (cnt >= 2)
			printf("^%d", cnt);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值