poj1458 Common Subsequence (dp,最长公共子序列)

题目链接:

http://poj.org/problem?id=1458


Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 46650 Accepted: 19171

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Source


题意:

给你2个字符串序列,求两个字符串的最大公共子序列,当然要保证字符之间的相对顺序不发生改变解题思路:

解题思路:

假设第一个字符串长度为len1,第二个字符串长度为len2。

若我们用数组dp[i][j]表示 当第一个字符串长度为 i ,第二个字符串长度为 j的时候的最长公共子序列长度,则所求答案为dp[len1][len2]
那么要怎么从其他状态转移过来呢,他的前一个状态可能是 dp[i-1][j-1],可能是dp[i-1][j] ,也可能是dp[i][j-1]。

若第一个字符串第 i 个字符与 第二个字符串第 j 个字符的是相同的,那么dp[i][j] 就是 dp[i-1][j-1] +1了。

若不同,只要在 dp[i][j-1],dp[i-1][j-1],dp[i-1][j] 3个状态即可。


AC代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<set>
#include<cmath>
#include<vector>
#include<map>
using namespace std;
typedef long long ll;
const int maxn  = 1010;
char str1[maxn];
char str2[maxn];
int dp[maxn][maxn];
int main()
{
    while(~scanf("%s%s",str1,str2))
    {
        int len1 = strlen(str1);
        int len2 = strlen(str2);
        memset(dp,0,sizeof(dp));
        for(int i = 0 ; i < len1; i++)
            for(int j = 0; j < len2; j++)
            {
                dp[i+1][j+1] = dp[i][j];
                if(str1[i]==str2[j])
                    dp[i+1][j+1] = dp[i][j] + 1;
                else
                    dp[i+1][j+1] = max(dp[i+1][j],dp[i][j+1]);
            }
        cout << dp[len1][len2]<<endl;
    }

    return 0 ;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值