题目描述:
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
题目分析:
每次输入两组序列,找出两组序列中公共最长子序列。
代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn=1010;
int dp[maxn][maxn];
char s1[maxn],s2[maxn];
int main()
{
while(scanf("%s%s",s1,s2)!=EOF)
{
int m=strlen(s1);
int n=strlen(s2);
memset(dp,0,sizeof(dp));
for(int i=1;i<=m;i++)
for(int j=1;j<=n;j++)
{
if(s1[i-1]==s2[j-1])
dp[i][j]=dp[i-1][j-1]+1;
else
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
printf("%d\n",dp[m][n]);
}
return 0;
}
上述代码中,dp[][]为二维数组,其中dp[i][j]=m代表第一组序列的前i个元素,第二组序列中的前j个元素,两组序列公共子序列长度是m。
状态转移方程为:
if(s1[i-1]==s2[j-1])
dp[i][j]=dp[i-1][j-1]+1;
else
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
上方关系中: 当s1[i-1] == s2[j-1]时, s1的第i个字符和s2的第j个字符必然在s1[1..i]和s2[1..j]的最长公共子序列中,
所以dp[i][j]==dp[i-1][j-1]+1.
当s1[i] != s2[j]时, s1[i]和s2[j]至少有一个是不可能在s1[1..i]和s2[1..j]的最长公共子序列中的,
所以dp[i][j] = max( dp[i-1][j] , dp[i][j-1] )
来自: 链接