L3-016. 二叉搜索树的结构

L3-016. 二叉搜索树的结构

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

二叉搜索树或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值;若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值;它的左、右子树也分别为二叉搜索树。(摘自百度百科)

给定一系列互不相等的整数,将它们顺次插入一棵初始为空的二叉搜索树,然后对结果树的结构进行描述。你需要能判断给定的描述是否正确。例如将{ 2 4 1 3 0 }插入后,得到一棵二叉搜索树,则陈述句如“2是树的根”、“1和4是兄弟结点”、“3和0在同一层上”(指自顶向下的深度相同)、“2是4的双亲结点”、“3是4的左孩子”都是正确的;而“4是2的左孩子”、“1和3是兄弟结点”都是不正确的。

输入格式:

输入在第一行给出一个正整数N(<= 100),随后一行给出N个互不相同的整数,数字间以空格分隔,要求将之顺次插入一棵初始为空的二叉搜索树。之后给出一个正整数M(<= 100),随后M行,每行给出一句待判断的陈述句。陈述句有以下6种:

  • "A is the root",即"A是树的根";
  • "A and B are siblings",即"A和B是兄弟结点";
  • "A is the parent of B",即"A是B的双亲结点";
  • "A is the left child of B",即"A是B的左孩子";
  • "A is the right child of B",即"A是B的右孩子";
  • "A and B are on the same level",即"A和B在同一层上"。

题目保证所有给定的整数都在整型范围内。

输出格式:

对每句陈述,如果正确则输出“Yes”,否则输出“No”,每句占一行。

输入样例:
5
2 4 1 3 0
8
2 is the root
1 and 4 are siblings
3 and 0 are on the same level
2 is the parent of 4
3 is the left child of 4
1 is the right child of 2
4 and 0 are on the same level
100 is the right child of 3
输出样例:
Yes
Yes
Yes
Yes
Yes
No
No
No
解析:
思路:先建树,再遍历判断。(这题很简单的,只是操作有点繁琐)
有三点要注意 1,判断是否同双亲,不能用abs(xid-yid)==1判断,上一层的最后一个和本层第一个也满足但是不同双亲;2,查询的点可能不是在0-n-1之内;3查询的A和B可能是同一点(这也是我最后一个数据没过的原因)
#include <stdio.h>
#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
int n;
int x,y,flag;
vector<int>a(10000,-1);
void build(int num,int index)
{
    if(a[index]==-1)
    {
        a[index]=num;
        return;
    }
    if(num<a[index])
        build(num,2*index);
    else
        build(num,2*index+1);
}
int xid,yid;
void find()
{
    xid=yid=-1;
    for (int i=1; i<10000; i++)
    {
        if(a[i]==x)   //x与y可能是同一点,所以不用if ; else if 组合。
            xid=i;
        if(a[i]==y)
            yid=i;
        if(xid!=-1&&yid!=-1)
            break;
    }

}
void j1()//"A and B are siblings"
{
    find();
    if(xid/2==yid/2)
        flag=1;
}
void j2()//A and B are on the same level
{
    find();
    if((int)log2(xid)==(int)log2(yid))
        flag=1;
}
void j3()//A is the parent of B
{
    find();
    if(yid/2==xid)
        flag=1;
}
void j4(int tmp)
{
    find();
    if(tmp)
    {
        if(2*yid+1==xid)
            flag=1;
    }
    else if(2*yid==xid)
        flag=1;
}
int main ()
{
    scanf("%d",&n);
    for (int i=0; i<n; i++)
    {
        int tmp;
        scanf("%d",&tmp);
        build(tmp,1);
    }
    int m;
    scanf("%d",&m);
    while(m--)
    {
        flag=0;
        string s1,s2;
        cin>>x>>s1;
        if(s1=="and")
        {
            cin>>y>>s1>>s2;
            if(s2[0]=='s')
            {
                j1();
            }
            else
            {
                cin>>s1>>s1>>s1;
                j2();
            }

        }
        else
        {
            cin>>s1>>s2;
            if(s2[0]=='r')
            {
                if(s2[1]=='i')
                {
                    cin>>s1>>s2>>y;
                    j4(1);
                }
                else if(x==a[1])
                    flag=1;
            }
            else if(s2[0]=='p')
            {
                cin>>s1>>y;
                j3();
            }
            else if(s2[0]=='l')
            {
                cin>>s1>>s2>>y;
                j4(0);
            }
        }
        if(xid==-1||yid==-1)//可能不是0-n-1上的点。所以find()之后xid,与yid的值可能不改变。
            flag=0;
        if(flag)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值