PAT甲级1094

PAT甲级1094

由于过年加考研分出来博主停更了几天现在恢复

题目:
A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4

题目考的是简单的DFS遍历,大意是说找节点数最多的那一层,定义全局数组存放每层的节点数,还有可以额外加个变量记录最大节点数的层数,省的主函数里再循环一次;或者也可以录入数据后用BFS层序遍历查找,node结构体加个height记录该节点所在的层数

#include <iostream>
#include <vector>
using namespace std;

struct node{
	vector<int> child;
};
vector<node> v;
int max_index=1;
int member[100]={0,1,0};
void DFS(int index,int height){
	int n=v[index].child.size();
	if(n==0) return ;
	member[height+1]+=n;
	if(member[height+1]>member[max_index]) max_index=height+1;
	for(int i=0;i<n;i++){
		DFS(v[index].child[i],height+1);
	}
}
int main(){
	int n,m,tmp,num,ch,max,index;
	scanf("%d%d",&n,&m);
	v.resize(n+1);
	for(int i=0;i<m;i++){
		scanf("%d%d",&tmp,&num);	//第tmp个节点有num个孩子
		for(int j=0;j<num;j++){
			scanf("%d",&ch);
			v[tmp].child.push_back(ch);
		}
	}
	DFS(1,1);
	printf("%d %d",member[max_index],max_index);
	system("pause");
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值