POJ3069 Saruman's Army

Saruman's Army
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.


题意
给定 n (1 <= n <= 1000)个点的位置 ai(0 <= i <= n, 0 <= ai <= 1000),和覆盖半径 r (0 <= r <=1000)。每个点可以被标记,标记后可以覆盖以它为圆心, r 为半径的所有点,求覆盖这 n 个点的最少标记点数。

分析
升序sort,枚举每个点为圆心的情况。将其想象在一条数轴上,以a[0]为圆心,向右覆盖,再以最后一个覆盖的点 id 为圆心向右继续覆盖。则左右两部分覆盖的点都在以 a[id] 为圆心 r 为半径的圆内,即满足条件,标记点+1。一直枚举到最后一个点。

AC代码如下

#include <cstdio>
#include <algorithm>
#define maxn 1000+2

using namespace std;

int a[maxn];
int main()
{
    int r,n,l;
    while(~scanf("%d%d",&r,&n) && r != -1 && n != -1)
    {
        for(int i = 0 ; i < n; i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        int id = 0;
        int ans = 0;
        while(id < n)
        {
            l = a[id] + r;
            while(a[id] <= l && id < n) id++;<span style="white-space:pre">		</span>//枚举每个点,<span style="font-family: Arial, Helvetica, sans-serif;">以该点为圆心向右覆盖</span>
            l = a[id-1] + r;<span style="white-space:pre">				</span>//记录标记点
            while(a[id] <= l && id < n) id++;<span style="white-space:pre">		</span>//以标记点为圆心向右覆盖
            ans++;<span style="white-space:pre">					</span>//标记点数量更新
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值