【poj2406】 Power Strings (KMP求循环节)

Power Strings

Time Limit : 6000/3000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 5
Problem Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
 

Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
 

Output
For each s you should print the largest n such that s = a^n for some string a.
 

Sample Input
   
   
abcd aaaa ababab .
 

Sample Output
   
   
1 4 3
 

Source
PKU
 总结:KMP求循环节
if(i%(i-next[i])==0)则循环节存在,并且循环节长度就是 i/(i-next[i]. (i为字符串的长度)

#include<cstdio>
#include<cstring>
int next[1000005];
char s[1000005];
int getNext(char P[])
{
     int j=0,k=-1;
     next[0]=-1;
     int len=strlen(P);
     while(j<len)
     {
                 if(k==-1||P[k]==P[j])
                 {
                    j++;k++;
                    next[j]=k;
                 }
                 else k=next[k];
     }
     if(len%(len-next[len])==0) 
        return len/(len-next[len]); 
     return 1;
}
int main()
{
    while(scanf("%s",s)&&s[0]!='.')
    {
         printf("%d\n",getNext(s));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值