【hdu】 Pseudoprime numbers 伪素数(快速幂+判定素数)


Pseudoprime numbers

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 3
Problem Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

 

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

 

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

 

Sample Input
   
   
3 2 10 3 341 2 341 3 1105 2 1105 3 0 0
 

Sample Output
   
   
no no yes no yes yes
 

Source
PKU
 

// 8.16.cpp : 定义控制台应用程序的入口点。
//

#include "stdafx.h"


#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#define LL long long
using namespace std ;
bool isPrime(int a)
{
	for(int i=2;i*i<=a;i++)
		if(a%i==0) return false;
	return true;
}
LL f(LL a,LL b,LL c)
{
	LL k=1;
	while(b>=1)
	{
		if(b&1) k=k*a%c;
		a=a*a%c;
		b>>=1;
	}
	return k;
}
int main()
{
	LL p,a;
	while(scanf("%lld%lld",&p,&a),(p||a))
	{
		LL res=f(a,p,p);
		if(res==a%p&&!isPrime(p))puts("yes");
		else puts("no");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值