【hdu】 Nightmare

Nightmare

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 4
Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
   
   
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
   
   
4 -1 13
 
这道题真是把人搞伤了,关键在于并不是根据它有没有被访问过而放不放入队列(visit数组),而是在于当前tt.t<mark[tt.x][tt.y],mark比tt.t后更新
// www.cpp : 定义控制台应用程序的入口点。
//

#include "stdafx.h"


#include<cstdio>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f3f
#define MEM(arr,w) memset(arr,w,sizeof(arr))
#define MAX 10
using namespace std;
struct node
{
	int x,y,t,sum;//t已用时间,sum实际走过多少步
}st,ed,ss,tt;
int dir[4][2]={0,1,1,0,0,-1,-1,0};
int map[MAX][MAX],mark[MAX][MAX];
int n,m,mint;
bool Judge(node s)
{
	if(s.x>=0&&s.x<n&&s.y>=0&&s.y<m&&map[s.x][s.y]!=0)return 1;
	return 0;
}
void Init()
{
	MEM(mark,INF);
	mint=INF;
}
void BFS()
{ //0墙壁,1大路,2起始点,3出口,4复位炸弹 
	queue<node> Q;
	Q.push(st);
	mark[st.x][st.y]=0;
	while(!Q.empty())
	{
		ss=Q.front();
		Q.pop();
		if(map[ss.x][ss.y]==4&&ss.t<6) {ss.t=0;mark[ss.x][ss.y]=0;}//关键!
		if(ss.x==ed.x&&ss.y==ed.y) if(ss.t<=5&&mint>ss.sum) mint=ss.sum;
		for(int i=0;i<4;i++)
		{
			tt.x=ss.x+dir[i][0];
			tt.y=ss.y+dir[i][1];
			tt.t=ss.t+1;
			tt.sum=ss.sum+1;
			if(Judge(tt))
			{			
				if(tt.t<mark[tt.x][tt.y]) 
				{
					mark[tt.x][tt.y]=tt.t;
					Q.push(tt);
				}

			}
		}
	}	
}
int main()
{
	int T,i,j;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				scanf("%d",&map[i][j]);
				if(map[i][j]==2) st.x=i,st.y=j,st.t=0,st.sum=0;
				if(map[i][j]==3) ed.x=i,ed.y=j;
			}
			Init();
			BFS();
			if(mint!=INF) printf("%d\n",mint);
			else puts("-1");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值