Anti-prime Sequences
Time Limit : 6000/3000ms (Java/Other) Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 8 Accepted Submission(s) : 5
Problem Description
Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence.
We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9.
We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9.
Input
Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.
Output
For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output
No anti-prime sequence exists.
No anti-prime sequence exists.
Sample Input
1 10 2 1 10 3 1 10 5 40 60 7 0 0 0
Sample Output
1,3,5,4,2,6,9,7,8,10 1,3,5,4,6,2,10,8,7,9 No anti-prime sequence exists. 40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54
Source
PKU
// 8.16.cpp : 定义控制台应用程序的入口点。
//
#include "stdafx.h"
#include<cstdio>
#include<cstring>
#define MAX 10500
int n,m,d;
int flag[MAX],res[MAX],prime[MAX+1];
bool fflag;
void Prime()
{
prime[1]=1;
for(int i=2;i*i<=MAX;i++)
{
if(!prime[i])
{
for(int j=i<<1;j<=MAX;j+=i)
prime[j]=1;
}
}
}
bool check(int k)
{
if(k==0) return true;
int sum=res[k];
for(int i=k-1;i>=0&&i>=k-d+1;i--)
{
sum+=res[i];
if(!prime[sum]) return false;
}
return true;
}
void DFS(int k)//k表示当前res数组所装元素的大小
{
if(k==m-n+1)
{
fflag=true;
for(int i=0;i<=m-n;i++)
{
if(i==0) printf("%d",res[i]);
else printf(",%d",res[i]);
}
return ;
}
if(fflag)return ;
for(int i=n;i<=m;i++)
{
if(!flag[i])
{
if(fflag)return ;
res[k]=i;
if(check(k))
{
flag[i]=true;
DFS(k+1);
if(fflag)return ;
flag[i]=false;
}
}
}
}
int main()
{
Prime();
while(scanf("%d%d%d",&n,&m,&d),(n||m||d))
{
fflag=false;
memset(flag,false,sizeof(flag));
DFS(0);
if(!fflag) printf("No anti-prime sequence exists.");
puts("");
}
return 0;
}