hdoj5363Key Set(快速幂+同余定理)

117 篇文章 0 订阅
5 篇文章 0 订阅
Description
soda has a set with integers . A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of are key set.

Input
There are multiple test cases. The first line of input contains an integer , indicating the number of test cases. For each test case:

The first line contains an integer , the number of integers in the set.

Output
For each test case, output the number of key sets modulo 1000000007.

Sample Input
4
1
2
3
4

Sample Output
0
1
3

7

题意:给你一个数n代表1~n这个序列。问这个序列有多少个子序列钥匙序列(序列和是偶数成为钥匙序列)。

思路:观察可以发现钥匙序列和是2^n -1,因为数据过大,直接写for循环求次方会超时.这里就要用到快速幂这个技巧了.简单说就是降幂,比如说a的b次方,如果b是偶数,该数就可以表示为(a^2)^(b/2),如果b是奇数,可以 另写一个数保存此时的底数然后幂数减1,又可以继续降幂了,知道最后。优化代码。__int64防止爆

代码:
#include<cstdio>
int quickpow(__int64 n,__int64 m,__int64 mod)//n是底数,m是幂数,mod是取余数
{
	__int64 ans=1,base=n;//如果幂数是奇数,则将底数保存在ans中,这样幂数-1变成偶数就可以继续降幂了。 base是幂数。
	while(m)
	{
		if(m&1)
		{
			ans=(base*ans)%mod;//保存并更新多幂底数
		}
		base=(base*base)%mod;//更新底数
		m/=2;//更新幂数
	}
	return ans;
}

int main()
{
	__int64 n,m;
	__int64 mod=1000000007;
	scanf("%I64d",&m);
	while(m--)
	{
	scanf("%I64d",&n);
	printf("%I64d\n",quickpow(2,n-1,mod)-1);	
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值