hdoj1241Oil Deposits(DFS)

117 篇文章 0 订阅
11 篇文章 0 订阅
Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output
0
1
2

2

题意:判断土地有几大块油田。如果油田上下左右左上左下右上右下八个方向是油田的话那么他们可以组成一个大块油田。
思路:DFS原来的四个方向换成了八个方向,搜索,这里定位几块大油田可以记录有多少块小油田,然后每搜索一次,减去相连的小油田块数(这里所有小油田组成了一块大油田),更新剩下的小油田块数并更新大油田块数直到记录小油田数为0;
代码:
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
char map[1110][1110];
int shi[1110][1110];
int vis[1110][1110];
int ans;
int n,m;
void dfs(int x,int y)
{
	if(map[x][y]=='*'||vis[x][y]||x<0||x>=n||y<0||y>=m)
	return;
	if(vis[x][y]==0)
	ans++;
	vis[x][y]=1;
	dfs(x+1,y);dfs(x-1,y);
	dfs(x,y+1);dfs(x,y-1);
	dfs(x+1,y+1);dfs(x+1,y-1);
	dfs(x-1,y+1);dfs(x-1,y-1);
}
int main()
{
	while(scanf("%d%d",&n,&m)&&n||m)
	{
		memset(shi,0,sizeof(shi));
		memset(map,0,sizeof(map));
		memset(vis,0,sizeof(vis));
		int i,j;
		int p=0;
		for(i=0;i<n;i++)
		{
			scanf("%s",map[i]);
			for(j=0;j<m;j++)
			{
				if(map[i][j]=='@')
				{
					shi[i][j]=1;
					p++;
				}
			}
		}
		int sum=0;
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
		{
			if(shi[i][j]==1)
			{	
				ans=0;
				dfs(i,j);
				if(p>0)
				{
				if(ans<=p&&ans>0)
				{
					sum++;
					p-=ans;
					ans=0;
				}	
				}
				else
				break;
			}
		}	
		if(p==0)
		break;
		}
		printf("%d\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值