POJ - 1017 (贪心)

POJ - 1017 (贪心)
A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.
Input
The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.
Output
The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.
Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1

题意:给出边长为1-6的正方形的数量, 给出一些边长为6的正方形,求最少用几个正方形能存下给出的所有正方形。

分析:边长4,5,6的都要单独占一个,3的情况比较复杂,1,2优先插入3,4,5,6.

收获:分别考虑不同的正方形,最后结合。

#include <iostream>
#include <cstdio>
using namespace std;
int s[10];
int u[4]= {0,5,3,1};
int main ()
{
    int flag=1;
    while(1)
    {
        flag=0;
        for(int i=1; i<=6; i++)
        {
            scanf("%d",&s[i]);

        }
        if(!s[1]&&!s[2]&&!s[3]&&!s[4]&&!s[5]&&!s[6])break;
        int n=s[6]+s[5]+s[4]+(s[3]+3)/4;
        int y=5*s[4]+u[s[3]%4];
        if(s[2]>y) n+=(s[2]-y+8)/9;
        int sum = 0;
        for(int i=2; i<=6; i++)
        {
            sum += s[i]*i*i;
        }
        int leave=36*n-sum;
        if(s[1]>leave)
            n+=(s[1]-leave+35)/36;
        printf("%d\n",n);

    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值