POJ 3723(裸体Kruskal)

有关系的男女之间要建立最大生成树,每建立一条通路就意味着会有多一个的人不通过10000/人的方式进入。记录以不同方式进入队伍的人的个数和这些人的总耗费,最后加上耗费,总人数里减去这些人数就可以了。

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output
For each test case output the answer in a single line.
Sample Input
2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133
Sample Output
71071
54223


#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int max_e=50005;
int father[max_e];
struct edge
{
    int u,v,cost;
};
int Find(int s)
{
    return father[s]==s?s:father[s]=Find(father[s]);
}
bool same(int a,int b)
{
    a=Find(a);
    b=Find(b);
    return a==b;
}
int v,e;//顶点数和边数
void init_union_find()//并查集的初始化
{
    for(int i=0; i<=v; i++)
    {
        father[i]=i;
    }
}

bool comp (const edge &e1,const edge &e2)
{
    return e1.cost <e2.cost;
}
edge es[max_e];
void unite(int a,int b)
{
    a=Find(a);
    b=Find(b);
    if(a!=b) father[a]=b;
}
int sum;
int Kruskal()
{
    sort(es,es+e,comp);//按照cost从小到大排序
    init_union_find();//并查集的初始化
    int res=0;
    sum=0;
    for(int i=0; i<e; i++)
    {
        edge e = es[i];
        if(!same(e.u,e.v))
        {
            unite(e.u,e.v);
            res+=e.cost;
            sum+=1;
        }
    }
    return res;

}
int main()
{
    int a,b;
    int k;
    scanf("%d",&k);
    while(k--)
    {
        scanf("%d%d%d",&a,&b,&e);
        for(int i=0; i<e; i++)
        {
            int c,d,f;
            scanf("%d%d%d",&c,&d,&f);
            es[i].u=c;
            es[i].v=d+a;
            es[i].cost=10000-f;
        }
        v=a+b;
        int n=Kruskal();
        printf("%d\n",n+(v-sum)*10000);
    }

    return 0;
}

 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值