PAT甲级真题 1004 Counting Leaves (30分) C++实现(广度遍历)

题目

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input
Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.
Sample Input
2 1
01 1 02
Sample Output
0 1

思路

建立map,每个非叶节点值为key,其孩子数组为value。

采用广度遍历的思路,将每层待遍历的非叶节点加入vector中,遍历每个非叶节点的所有孩子,按以下思路:

  1. 若该孩子出现在map的key中,即表示它是非叶节点,加入vector中;
  2. 若没出现,则是该层叶子,计数器+1;

初始化为{1},即从根开始;当vector为空时结束。

首先输出第1层叶子数:

  1. 节点总数为1时,输出1;
  2. 节点总数大于1时,输出0;

剩下每层遍历输出计数即可。

代码实现上:

  1. 用到了unordered_map,比map效率更高;
  2. vector可以直接互相赋值,a = b,相当于清空a,填充为b的元素。

代码

#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;

int main(){
    int n, m;
    cin >> n >> m;
    if (n>0){
        if (n==1){
            cout << 1;
        }
        else {
            unordered_map<int, vector<int> > mmap; //建立非叶节点号及孩子数组映射
            for (int i=0; i<m; i++){
                int p, k;
                cin >> p >> k;
                vector<int> nodes(k);
                for (int j=0; j<k; j++){
                    cin >> nodes[j];
                }
                mmap[p] = nodes;
            }
            vector<int> v;
            v.push_back(1);
            cout << "0";
            while (v.size()>0){
                int count = 0;
                vector<int> newV;
                for (int i=0; i<v.size(); i++){
                    for (int j=0; j<mmap[v[i]].size(); j++){
                        if (mmap.find(mmap[v[i]][j])==mmap.end()) {  //未出现在非叶中,是叶子
                            count++;
                        }
                        else {
                            newV.push_back(mmap[v[i]][j]);
                        }
                    }
                }
                v = newV;
                cout << " " << count;
            }

        }
        cout << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值