PAT甲级真题 1024 Palindromic Number (25分) C++实现(判断回文数,字符串模拟大数加法)

题目

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.
Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 10^10) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.
Output Specification:
For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.
Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3

思路

原创 PAT乙级真题 1079 延迟的回文数 C++实现几乎一样。

用字符串存储数字,模拟大数加法。每一位结果等于:

char temp = s[j] + s[n-1-j] + addition - '0'

其实只要都没有进位,结果肯定是回文数。但需要打印出反转后的结果,所以还得老实求出来每个和。

判断是否是回文数, 柳神用了reverse(s1.begin(), s1.end())反转字符串后,判断字符串s1==s是否成立;反转后的字符串顺便用于后序模拟加法,做上面乙级1079题时用了此方法。

做本题换了方法,不翻转字符串直接求和,然后根据定义判断是否是回文数,效率更高一点。

代码

#include <iostream>
using namespace std;

bool isPalin(string s){
    for (int i=0; i<s.size()/2; i++){
        if (s[i]!=s[s.size()-1-i]){
            return false;
        }
    }
    return true;
}
int main(){
    string s;
    int k;
    cin >> s >> k;
    
    int i = 0;
    while (i<k){
        if (isPalin(s)){
            cout << s << "\n" << i << endl;
            break;
        }
        string ans = "";
        int addition = 0;
        int n = s.size();
        for (int j=0; j<n; j++){
            char temp = (s[j] + s[n-1-j] + addition - '0');
            if (temp > '9'){
                temp -= 10;
                addition = 1;
            }
            else {
                addition = 0;
            }
            ans = temp + ans;
        }
        if (addition > 0){
            ans = '1' + ans;
        }
        s = ans;
        i++;
    }
    if (i==k){
        cout << s << "\n" << i << endl;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值