PAT甲级真题 1046 Shortest Distance (20分) C++实现 (环形两点间最小距离,找基准点)

题目

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

思路

一开始用了笨方法,记录各段距离,每次求两点距离时都累加一遍,复杂度O(mn),最后一个测试点果断超时……

后参考了柳神的方法:以0号节点为基准,用dist[i]表示每个节点到0号的距离,dist[0] = 0,这样可以直接用dist[i] - dist[j]求出j到i的距离。由于是环形,距离只有正向反向两种可能,二者和是周长,计算出一边的距离lenmin{len, sum-len}即为所求,复杂度O(n)。

代码

#include <iostream>
#include <vector>
using namespace std;

int main(){
    int n;
    cin >> n;
    vector<int> dist(n+1);
    int sum = 0;  //周长
    for(int i = 1; i <= n; i++){
        int d;
        cin >> d;
        sum += d;
        dist[i] = sum;
    }

    int m;
    cin >> m;
    for(int i = 0; i < m; i++){
        int s, t;
        cin >> s >> t;
        if (s > t){
            swap(s, t);
        }
        int len = dist[t-1] - dist[s-1];
        cout << min(len, sum - len) << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值