1046 Shortest Distance (20 分) 环中两点的最短路径

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10^​5]), followed by N integer distances D​1 D2 ⋯ DN, where D​i is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10 ^​4), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10 ^7.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

题意:输入n个整数,分别为第i个点到第i+1个点的距离,最后一个数为最后一个顶点和起点的距离,再输入m对整数,分别求出这m对整数之间的最小距离。
思路:这n个整数组成了环,比较的就是顺序和和环的长度减去顺序和的长度之间的比较。

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>

using namespace std;

int n,m;

int main() {
	scanf("%d",&n);
	vector<int> v(n + 1);
	v[0] = 0;
	int sum = 0;
	int x;
	for(int i = 1;i <= n;i++) {
		scanf("%d",&x);
		sum = sum + x;
		v[i] = sum;
	}
	int a,b;
	scanf("%d",&m);
	for(int i = 0;i < m;i++) {
		scanf("%d%d",&a,&b);
		if(a > b) {
			swap(a,b);
		}
		int result = v[b - 1] - v[a - 1];
		result = min(result,sum - result);
		printf("%d\n",result);
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值