PAT甲级真题 1062 Talent and Virtue (25分) C++实现(同乙级1015,简单sort排序)

题目

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people’s talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a “sage(圣人)”; being less excellent but with one’s virtue outweighs talent can be called a “nobleman(君子)”; being good in neither is a “fool man(愚人)”; yet a fool man is better than a “small man(小人)” who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang’s theory.

Input Specification:
Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤10 ^ 5), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades – that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification – that is, those with both grades not below this line are considered as the “sages”, and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the “noblemen”, and are also ranked in non-increasing order according to their total grades, but they are listed after the “sages”. Those with both grades below H, but with virtue not lower than talent are considered as the “fool men”. They are ranked in the same way but after the “noblemen”. The rest of people whose grades both pass the L line are ranked after the “fool men”.

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:
The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID’s.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

思路

连续遇到重复乙级题:
PAT乙级真题 1015 德才论

题目给出的要求有:

  • 得和才>=L才能被记录;
  • 得和才>=H是圣人,按总分递减排序;
  • 才 < H,得 >= H是君子,按总分递减排序,排在圣人之后;
  • 才 < H, 得 < H,但得 >= 才是蠢人,按总分递减排序,排在君子之后;
  • 剩下的是小人,排在蠢人之后;
  • 所有总分相同的,按得递减排序;若得也相同,按ID号递增排序;

用结构体存储每个人的id、得、才分数,并额外设置标记level,level越小排名越靠前:

圣人是0,君子是1,愚人是2,小人是3;

将所有符合条件的人加入数组中统一排序即可。

代码

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

struct Person{
    int id;
    int v;
    int t;
    int level;
};
bool cmp(Person &p1, Person &p2){
    if (p1.level == p2.level){
        if (p1.v + p1.t == p2.v + p2.t){
            if (p1.v == p2.v) {
                return p1.id < p2.id;
            }
            return p1.v > p2.v;
        }
        return (p1.v + p1.t > p2.v + p2.t);
    }
    return p1.level < p2.level;
}
int main(){
    int n, l, h;
    scanf("%d %d %d", &n, &l, &h);
    vector<Person> P;
    for (int i=0; i<n; i++){
        int id, v, t;
        scanf("%d%d%d", &id, &v, &t);
        if (v>=l && t>=l){
            if (v >= h){
                if (t >= h){
                    P.push_back({id, v, t, 0});
                }
                else{
                    P.push_back({id, v, t, 1});
                }
            }
            else if(v >= t){
                P.push_back({id, v, t, 2});
            }
            else{
                P.push_back({id, v, t, 3});
            }
        }
    }
    sort(P.begin(), P.end(), cmp);
    printf("%d\n", (int)P.size());
    for (int i=0; i<P.size(); i++){
        printf("%08d %d %d\n", P[i].id, P[i].v, P[i].t);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值