PAT甲级真题 1063 Set Similarity (25分) C++实现(set数组+结果备忘录)

题目

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt​ ×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and Nt
is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:
Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤104​​ ) and followed by M integers in the range [0,109​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:
For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

思路

建立set数组,读入每个set的数据时直接自动排除掉重复元素。

对比两个set时,遍历其中一个,在另一个之中寻找是否有相同元素,记录总数count。所求比例即为 count / (两个set长度之和 - count)

将求得的结果记录到result数组里,方便后面重复使用(比如查询1、2后再查询2、1)。

注意计算比值时要保证是float类型的数字运算,两个整型相除会丢失精度。

用printf打印百分号的方法是:printf("%%")

代码

#include <iostream>
#include <set>
#include <vector>
using namespace std;

int main(){
    int n;
    scanf("%d", &n);
    vector<set<int> > v(n);
    for (int i=0; i<n; i++){
        int m;
        scanf("%d", &m);
        for (int j=0; j<m; j++){
            int temp;
            scanf("%d", &temp);
            v[i].insert(temp);
        }
    }
    vector<vector<float> > result(n, vector<float>(n, -1.0));  //结果备忘录
    int k;
    scanf("%d", &k);
    for (int i=0; i<k; i++){
        int a, b;
        scanf("%d %d", &a, &b);
        a--;
        b--;
        if (result[a][b] == -1.0){
            int count = 0;
            for (auto it=v[a].begin(); it!=v[a].end(); ++it){
                if (v[b].find(*it) != v[b].end()){
                    count++;
                }
            }
            result[a][b] = 100.0 * count / (v[a].size() + v[b].size() - count);
            result[b][a] = result[a][b];
        }
        printf("%.1f%%\n", result[a][b]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值