PAT甲级真题 1065 A+B and C (64bit) (20分) C++实现(大数加法,预处理防溢出)

题目

Given three integers A, B and C in [−2​63, 263], you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

思路

  • 若A、B异号或其中一个为0,则可直接相加;
  • 若A、B > 0。若C <= 0,则直接true;若C > 0,转换为A > C - B
  • 若A、B < 0。若C >= 0,则直接false;若C < 0,转换为A > C - B

也可以利用溢出后变号的规律,最大值+1 = 最小值,相当于取值范围是首尾相连的:

a:    9223372036854775807
a+1: -9223372036854775808

若两个正数相加后溢出,则A + B 一定大于C。
若两个负数相加后溢出,则A + B 一定小于C。
若不溢出,则直接验证A + B > C即可。

代码

#include <iostream>
using namespace std;

int main(){
    long long n;
    cin >> n;
    for (int i=0; i<n; i++){
        long long a, b, c;
        cin >> a >> b >> c;
        bool ret = false;
        if ((a^b)<0 || (a&b)==0){  //a、b异号,或有一个为0
            if (a + b > c) {
                ret = true;
            }
        }
        else{  //a、b同号
            if (a>0 && b>0){
                if (c <= 0){
                    ret = true; 
                }
                else if (a > c - b){
                        ret = true; 
                }
            }
            else if(c<0 && a>c-b){
                ret = true;
            }
        }
        cout << "Case #" << i + 1;
        if (ret){
            cout << ": true" << endl;;
        }
        else{
            cout << ": false" << endl;;
        }
    }
    return 0;
}

利用溢出的方法:

#include<iostream>

using namespace std;

int main(){
    int n;
    cin >> n;
    for (int i=0; i<n; i++){
        long long a, b, c;
        bool ret = false;			
        cin >> a >> b >> c;
        long long sum = a + b;
        if(a>0 && b>0 && sum<=0) ret = true;
        else if(a<0 && b<0 && sum>=0) ret = false;
        else if(sum > c) ret = true;
        cout << "Case #" << i + 1;
        if (ret){
            cout << ": true" << endl;;
        }
        else{
            cout << ": false" << endl;;
        }
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值