PAT甲级真题 1080 Graduate Admission (30分) C++实现(报志愿问题)

题目

It is said that in 2013, there were about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred shcool is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case. Each case starts with a line containing three positive integers: N (<=40,000), the total number of applicants; M (<=100), the total number of graduate schools; and K (<=5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant’s GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Output Specification:
For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:
0 10
3
5 6 7
2 8

1 4

思路

不能从学校的角度出发划学生,因为每个学生能报多个学校,只能按排名顺序考察学生,一个个选学校。

将学生按总分-考试分优先级排序。按顺序逐个考察学生,用rank[id]记录每个学生的排名,用二维数组admit[i][j]记录学校i录取学生的id。

若学校名额未满则可直接录取;若学校名额满了,只需比较该学生排名是否与学校已录取的最后一名的rank[id],若相同则将其录取。

最后对每个admit[i]排序后输出即可。

(注意需要额外记录每个学生的id号,因为后面重新排序后还要使用原先的编号)

代码

#include <iostream>
#include <vector>
#include <set>
#include <algorithm>
using namespace std;

struct Student{
    int id;
    int ge;
    int gi;
    vector<int> option;
};
bool cmp(Student &s1, Student &s2){
    float sum1 = (s1.ge + s1.gi) / 2.0;
    float sum2 = (s2.ge + s2.gi) / 2.0;
    return sum1==sum2 ? s1.ge>s2.ge : sum1>sum2; 
}
int main(){
    int n, m, k;
    scanf("%d %d %d", &n, &m, &k);
    vector<int> quota(m);
    for (int i=0; i<m; i++){
        scanf("%d", &quota[i]);
    }
    vector<Student> t(n);
    for (int i=0; i<n; i++){
        t[i].id = i;
        t[i].option.resize(k);
        scanf("%d %d", &t[i].ge, &t[i].gi);
        for (int j=0; j<k; j++){
            scanf("%d", &t[i].option[j]);
        }
    }
    sort(t.begin(), t.end(), cmp);
    vector<int> rank(n);
    vector<vector<int> > admit(m);
    for (int i=0; i<n; i++){
        int id = t[i].id;
        if(i>0 && t[i].ge==t[i-1].ge && t[i].gi==t[i-1].gi){
            rank[id] = rank[t[i-1].id];
        }
        else{
            rank[id] = i;
        }
        for (int j=0; j<k; j++){
            int k = t[i].option[j];  //当前志愿
            if (quota[k] > 0){  //学校名额未满
                admit[k].push_back(t[i].id);
                quota[k]--;
                break;
            }
            //学校名额满了,看该学校最后一名是否与其排行相同
            else if (rank[id] == rank[admit[k][admit[k].size()-1]]){
                admit[k].push_back(t[i].id);
                break;
            }
        }
    }
    for (int i=0; i<m; i++){
        sort(admit[i].begin(), admit[i].end());
        for (int j=0; j<admit[i].size(); j++){
            if (j>0) {
                printf(" ");
            }
            printf("%d", admit[i][j]);
        }
        printf("\n");
    }
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值