PAT甲级真题 1092 To Buy or Not to Buy (20分) C++实现(vector模拟map统计元素数量)

题目

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.
For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

在这里插入图片描述
Figure 1

Input Specification:
Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.
Output Specification:
For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

思路

用vector模拟map统计商店珠子的数量,读入买家需求时,每读一个就从商店存量数组中-1,减至0后累计入缺少的个数。若缺少数量>0,则输出No + 差值;否则输出Yes + 两字符串长度差。


一开始审题不够细,把题目想复杂了,以为商店的项链是可以截开的,当能满足需求时,要求出需要额外买的最小差值。于是分别从前端和后端不断截掉一个(计数–),每去掉一个计算一次是否仍然满足…

其实商店的项链是整根卖的,超出的数量直接等于两个字符串长度差。

代码

#include <iostream> 
#include <vector> 
using namespace std; 

int main() { 
    string s1, s2;
    cin >> s1 >> s2;

    vector<int> m(128);
    for (int i=0; i<s1.size(); i++){
        m[s1[i]]++;
    }

    int dif = 0;
    for (int i=0; i<s2.size(); i++){
        if (m[s2[i]]==0) {
            dif++;
        }
        else{
            m[s2[i]]--;
        }
    }

    if (dif > 0){
        cout << "No " << dif << endl;
    }
    else{
        cout << "Yes " << s1.size()-s2.size() << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值