hdu 3336 Count the string

点击打开链接

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11740    Accepted Submission(s): 5470


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
  
  
1 4 abab
 

Sample Output
  
  
6

题意很好明白,但是不能暴力拆分出每一个字串,然后去匹配,那样会超时。要充分利用next数组。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 200005;
char str[N];
int Next[N];
int len;
int mod=10007;
void getNext()
{
	Next[0]=-1;
	int i=0,j=-1;
	while(i<len)
	{
		if(j==-1||str[i]==str[j])
		{
			i++;
			j++;
			Next[i]=j;
		}
		else
			j=Next[j];
	}
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
    	scanf("%d%s",&len,str);
    	getNext();
    	int sum=Next[len]+len;
    	for(int i=0;i<len;i++)
    	{
    		if(Next[i]>0&&Next[i]+1!=Next[i+1])
    		{
    			sum=(sum+Next[i])%mod;
    		}
    	}
    	printf("%d\n",sum);
    }
    return 0;
}

参考网址:

http://972169909-qq-com.iteye.com/blog/1114968



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值